Bug 683352 - Installer unable to configure network on Atheros AR9285 wireless during install
Summary: Installer unable to configure network on Atheros AR9285 wireless during install
Keywords:
Status: CLOSED DUPLICATE of bug 673824
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-09 08:43 UTC by Jes Sorensen
Modified: 2011-05-23 16:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-23 16:36:20 UTC
Type: ---


Attachments (Terms of Use)
anaconda log (4.93 KB, text/plain)
2011-03-09 15:33 UTC, Jes Sorensen
no flags Details
syslog (89.98 KB, application/octet-stream)
2011-03-09 15:34 UTC, Jes Sorensen
no flags Details

Description Jes Sorensen 2011-03-09 08:43:26 UTC
Description of problem:
Trying to install the Fedora 15 Alpha DVD on an ASUS EEEPC 1215N
which has an Atheros AR9285 wireless card in it.

I get to the point where it asks to configure the network. When I
pick the wireless card, it tries to configure, but then just times
out and returns to the network config screen. I don't get prompted
by network manager for picking a wireless network and entering the
key.

I had to resolve to using a wired cable to get the installer to
continue.

I also noticed that anaconda didn't give me the option to install
without configuring a network.

Version-Release number of selected component (if applicable):
Fedora 15 Alpha x86_64 DVD

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jes Sorensen 2011-03-09 08:45:23 UTC
A note - when installing on wired Ethernet and I get to the point where
it asks for the hostname, I am then able to see the wifi networks and pick
one, so it looks like the driver is working correctly.

Comment 2 Chris Lumens 2011-03-09 15:10:33 UTC
Please attach /tmp/anaconda.log, /tmp/syslog, and /tmp/ifcfg* to this bug report.  Thanks.

Comment 3 Jes Sorensen 2011-03-09 15:33:49 UTC
Created attachment 483242 [details]
anaconda log

Comment 4 Jes Sorensen 2011-03-09 15:34:13 UTC
Created attachment 483243 [details]
syslog

Comment 5 Jes Sorensen 2011-03-09 15:35:16 UTC
I have attached anaconda.log and syslog, ifcfg is empty.

Note that I could only obtain these files after plugging in a wired
Ethernet as the installer refuses to continue past that stage until
it obtains an IP address.

Jes

Comment 6 Radek Vykydal 2011-03-21 15:41:47 UTC
Anaconda lacks UI for wireless configuration in loader, access point and authentication can be configured only in GUI of stage 2 (or with kickstart, limited to WEP, please see http://fedoraproject.org/wiki/Anaconda/Network#wireless for details). In your case you are probably hitting bug #673824 - anaconda should ask for network enablement only in stage 2 where you should be able to configure wireless with NetworkManager Connection Editor in the same way as in hostname screen.

Comment 7 Radek Vykydal 2011-05-23 16:36:20 UTC

*** This bug has been marked as a duplicate of bug 673824 ***


Note You need to log in before you can comment on or make changes to this bug.