Bug 673824 - [anaconda] prompts user for network device prematurely in netinst
Summary: [anaconda] prompts user for network device prematurely in netinst
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH
Keywords: Reopened
: 680410 683352 684490 (view as bug list)
Depends On:
Blocks: F15Beta-accepted, F15BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-01-30 18:58 UTC by Joachim Frieben
Modified: 2011-05-23 16:36 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-03-29 03:51:42 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2011-01-30 18:58:10 UTC
Description of problem:
After booting from http://alt.fedoraproject.org/pub/alt/stage/15-Alpha.TC1/Fedora/x86_64/iso/Fedora-15-Alpha-x86_64-netinst.iso for a wireless network install with option "allowwireless" (either with or without also specifying essid), anaconda prompts the user for the required network interface well -before- launching the graphical installer. After selecting interface wlan0, NM fails to create the connection which is no surprise since the AP is using WPA2 and no opportunity for entering AP and passphrase was given.

Version-Release number of selected component (if applicable):
anaconda-15.18-1.fc15.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot from Fedora-15-Alpha-x86_64-netinst.iso with option "allowwireless".

Actual results:
Installer prompts user for network device before launching graphical interface without the possibility to enter necessary configuration data.

Expected results:
Installer starts graphical interface without prompting the user for the network device and enables him to configure the network using the graphical network tool.

Additional info:
The F14 installer launches X without prompting for the network interface. Accordingly, "Configure Network" can be clicked in order to configure the network graphically including a WPA2 based wireless connection.

Comment 1 Chris Lumens 2011-01-31 17:01:34 UTC
allowwireless is for bringing up wireless in the loader, which is useful if you want to do things like fetch your kickstart file over wireless, etc.  You've got the ability to bring the wireless up later with Network Manager if you want.

Comment 2 Joachim Frieben 2011-01-31 17:25:25 UTC
(In reply to comment #1)
What if I want to connect to a WPA2 encrypted AP for fetching said kickstart file? File a new bug?

Comment 3 Radek Vykydal 2011-01-31 22:09:54 UTC
(In reply to comment #2)
> (In reply to comment #1)
> What if I want to connect to a WPA2 encrypted AP for fetching said kickstart
> file? File a new bug?

Yes, I want to add option of WPA2 authentication into kickstart. It would be good to have a reference bug.

Comment 4 Joachim Frieben 2011-02-02 21:02:24 UTC
The 15-Alpha.TC1 installer prompts the user for the network interface before launching the graphical interface regardless of whether "allowwireless" was added to the installer options or not.

Comment 5 Chris Lumens 2011-02-03 16:39:12 UTC
Because you are doing something that requires bringing up the network - fetching the kickstart file, fetching an updates image, etc. but have not told anaconda how to go about enabling the network to do this.  You either need to add command line arguments or answer the question in loader.  I'll reassign this to Radek to decide if he wants to use this as the reference bug, but anaconda is acting as it should here.

Comment 6 Joachim Frieben 2011-02-11 10:07:12 UTC
(In reply to comment #5)
Unfortunately, anaconda prompts for the network interface before firing up the graphical installer even when not a single boot option has been added.

A confirmation of this issue at test.lists.fedoraproject.org:

Thread: fc15 TC1 isos
John Watzke <watzkej gmail com>:
.. It prompted me for a network connection which I just cancelled ..

I do not know how John would cancel this step when only choices like "Back", "Identify", and "Ok" are given, forcing you to ensure a valid network connection at this point but he clearly confirms the basic issue.

Comment 7 Joachim Frieben 2011-02-15 08:08:19 UTC
The bug is also present for anaconda-15.20-1.fc15 included in the F15 Alpha TC2 netinst image. Contrary to John, I still haven't found a means to postpone network configuration until the graphical installer has fired up.
Note that the current netinst image behaves like the abandoned (mini) boot.iso which did -not- include stage2.img, and wich needed to download the graphical installer first. Boot option "askmethod" has exactly the same effect, but I haven't used this in any of my attempts.

Comment 8 Radek Vykydal 2011-02-15 12:19:24 UTC
Installation is not detected as METHOD_CDROM (so initial METHOD_URL is kept) as neither .discinfo, nor .treeinfo files are found on image in this chunk:

        if ((rc = doPwMount(devices[i]->device, "/mnt/source", "iso9660", "ro", NULL)) == 0) {
            if (!access("/mnt/source/.treeinfo", R_OK) && !access("/mnt/source/.discinfo", R_OK)) {
                 loaderData->method = METHOD_CDROM;
                 checked_asprintf(&loaderData->instRepo, "cdrom://%s:/mnt/source", devices[i]->device);
                 return LOADER_OK;
            } else {
                /* This wasn't the CD we were looking for.  Clean up and
                 * try the next drive.
                 */
                umount("/mnt/source");
            }
        }

We'd probably need a way to detect netinst image specifically and set loaderData->method to METHOD_CDROM while leaving loaderData->instRepo empty in the case of netinst.

Comment 9 Joachim Frieben 2011-02-15 17:54:50 UTC
(In reply to comment #8)
Just for the record: detection of METHOD_CDROM used to work ever since the fat boot.iso including stage2.img was introduced up to F14.

Comment 10 Joachim Frieben 2011-02-23 14:41:03 UTC
No improvement for anaconda-15.20.1-1.fc15.

Comment 11 Radek Vykydal 2011-02-24 17:59:38 UTC
We need to check loaderData->instRepo instead of loaderData->method in STEP_NETWORK. The latter is obsoleted by stage 2 moved into initrd.img since F15. I am thinking about F15 NiceToHave propsal.

Comment 12 Bruno Wolff III 2011-02-25 18:21:28 UTC
From alpha blocker review meeting #3:
#agreed 673824 rejected nth

Comment 13 Radek Vykydal 2011-03-02 12:01:59 UTC
*** Bug 680410 has been marked as a duplicate of this bug. ***

Comment 14 Radek Vykydal 2011-03-02 12:04:31 UTC
This affects also DVD on usb stick (bug #680410) and most probably also hd: installs.

Comment 15 Radek Vykydal 2011-03-03 11:09:12 UTC
As new use cases affected by the bug were found (comment #14), re-proposing as NiceToHave.

Comment 16 Chris Lumens 2011-03-14 17:17:20 UTC
*** Bug 684490 has been marked as a duplicate of this bug. ***

Comment 17 James Laska 2011-03-22 18:22:29 UTC
(In reply to comment #15)
> As new use cases affected by the bug were found (comment #14), re-proposing as
> NiceToHave.

Clearing whiteboard so this request actually is re-reviewed.  I support this as a nice-to-have for Beta.

Comment 18 Chris Lumens 2011-03-22 18:32:57 UTC
cherry-picked to f15-branch.

Comment 19 Fedora Update System 2011-03-25 15:40:34 UTC
anaconda-15.25-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.25-1.fc15

Comment 20 Fedora Update System 2011-03-26 04:50:58 UTC
Package anaconda-15.25-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.25-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.25-1.fc15
then log in and leave karma (feedback).

Comment 21 James Laska 2011-03-28 16:45:36 UTC
Adding AcceptedNTH since this is already included in anaconda-15.25-1

Comment 22 James Laska 2011-03-28 21:04:46 UTC
VERIFIED using anaconda-15.25-1 included in a custom built boot.iso

Comment 23 Fedora Update System 2011-03-29 03:51:33 UTC
anaconda-15.25-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Radek Vykydal 2011-05-23 16:36:20 UTC
*** Bug 683352 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.