Bug 683541 - cgconfig fails to parse commas in the cgconfig.conf file
Summary: cgconfig fails to parse commas in the cgconfig.conf file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libcgroup
Version: 14
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Dhaval Giani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-09 16:43 UTC by Ted
Modified: 2011-11-11 21:59 UTC (History)
5 users (show)

Fixed In Version: libcgroup-0.36.2-7.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 753334 (view as bug list)
Environment:
Last Closed: 2011-06-21 17:08:33 UTC


Attachments (Terms of Use)

Description Ted 2011-03-09 16:43:07 UTC
Description of problem:
cgconfig fails to parse due to commas in the conf file

Version-Release number of selected component (if applicable):
Problem seen in both: libcgroup-0.35.1-3.fc13, libcgroup-0.36.2-5.fc14 and probably other versions as well.

How reproducible:
Always

Steps to Reproduce:
1. Add a line to the config file that uses a comma for the mask.
For example:  cpuset.cpus = 1-3,11;

2. Attempt to start cgconfig

3. Fails due to parse error.
  
Actual results:
cgconfig fails to start

Expected results:
cgconfig starts successfully

Additional info:
adding a \, to the regular expression on line 35 of lex.l in the libcgroup source fixes it.

Comment 1 Dhaval Giani 2011-05-24 12:18:41 UTC
I believe this was fixed in the upstream sources, and probably an update has been delivered. Can you please confirm if it still exists for you?

Comment 2 Fedora Update System 2011-05-26 14:04:28 UTC
libcgroup-0.36.2-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libcgroup-0.36.2-7.fc14

Comment 3 Ivana Varekova 2011-05-26 14:06:14 UTC
The problem was not fixed in libcgroup-0.36.2-6.fc14 now libcgroup-0.36.2-7.fc14 should fix it.

Comment 4 Fedora Update System 2011-05-26 21:53:22 UTC
Package libcgroup-0.36.2-7.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libcgroup-0.36.2-7.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libcgroup-0.36.2-7.fc14
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-06-21 17:08:26 UTC
libcgroup-0.36.2-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.