Bug 753334 - cgconfig fails to parse commas in the cgconfig.conf file
cgconfig fails to parse commas in the cgconfig.conf file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup (Show other bugs)
6.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Schiffer
Petr Beňas
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 17:01 EST by Tru Huynh
Modified: 2015-01-04 18:01 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: missing support for commas in lexical analyser Consequence: cgconfig failed to parse commas in the cgconfig.conf file Fix: add support for commas in lexical analyser Result: cgconfig can parse commas in the cgconfig.conf file
Story Points: ---
Clone Of: 683541
Environment:
Last Closed: 2013-11-21 17:31:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libcgroup-0.37-comma.patch (557 bytes, patch)
2013-08-12 06:49 EDT, Peter Schiffer
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 5242 None None None Never

  None (edit)
Description Tru Huynh 2011-11-11 17:01:32 EST
+++ This bug was initially created as a clone of Bug #683541 +++

Description of problem:
cgconfig fails to parse due to commas in the conf file

Version-Release number of selected component (if applicable):
Problem seen in both: libcgroup-0.35.1-3.fc13, libcgroup-0.36.2-5.fc14 and probably other versions as well.

How reproducible:
Always

Steps to Reproduce:
1. Add a line to the config file that uses a comma for the mask.
For example:  cpuset.cpus = 1-3,11;

2. Attempt to start cgconfig

3. Fails due to parse error.
  
Actual results:
cgconfig fails to start

Expected results:
cgconfig starts successfully

Additional info:
adding a \, to the regular expression on line 35 of lex.l in the libcgroup source fixes it.

--- Additional comment from dhaval.bugzilla@thegianis.in on 2011-05-24 08:18:41 EDT ---

I believe this was fixed in the upstream sources, and probably an update has been delivered. Can you please confirm if it still exists for you?

--- Additional comment from updates@fedoraproject.org on 2011-05-26 10:04:28 EDT ---

libcgroup-0.36.2-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libcgroup-0.36.2-7.fc14

--- Additional comment from varekova@redhat.com on 2011-05-26 10:06:14 EDT ---

The problem was not fixed in libcgroup-0.36.2-6.fc14 now libcgroup-0.36.2-7.fc14 should fix it.

--- Additional comment from updates@fedoraproject.org on 2011-05-26 17:53:22 EDT ---

Package libcgroup-0.36.2-7.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libcgroup-0.36.2-7.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libcgroup-0.36.2-7.fc14
then log in and leave karma (feedback).

--- Additional comment from updates@fedoraproject.org on 2011-06-21 13:08:26 EDT ---

libcgroup-0.36.2-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 2 RHEL Product and Program Management 2011-11-11 17:28:54 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 Peter Schiffer 2013-08-12 06:49:59 EDT
Created attachment 785642 [details]
libcgroup-0.37-comma.patch
Comment 14 Petr Beňas 2013-09-16 09:47:25 EDT
Reproduced in libcgroup-0.37-7.el6.x86_64 and verified in libcgroup-0.37-10.el6.x86_64.
Comment 15 errata-xmlrpc 2013-11-21 17:31:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1685.html

Note You need to log in before you can comment on or make changes to this bug.