Bug 684205 - [abrt] libmtp-examples-1.0.5-2.fc15: Process /usr/bin/mtp-detect was killed by signal 11 (SIGSEGV)
[abrt] libmtp-examples-1.0.5-2.fc15: Process /usr/bin/mtp-detect was killed b...
Status: CLOSED DUPLICATE of bug 684214
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
abrt_hash:dd9134f5188104d690fd6b261ae...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-11 08:05 EST by Rex Dieter
Modified: 2011-04-01 08:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-01 08:12:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (3.41 KB, text/plain)
2011-03-11 08:05 EST, Rex Dieter
no flags Details

  None (edit)
Description Rex Dieter 2011-03-11 08:05:23 EST
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 3491 bytes
cmdline: mtp-detect
component: libmtp
Attached file: coredump, 634880 bytes
executable: /usr/bin/mtp-detect
kernel: 2.6.38-0.rc8.git0.1.fc15.x86_64
package: libmtp-examples-1.0.5-2.fc15
rating: 3
reason: Process /usr/bin/mtp-detect was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1299848409
uid: 500

comment
-----
I'm experiencing amarok crash on-statup on my f15 box, and it appeared to be within some mtp probing (via libmtp), so I installed libmtp-examples, and ran 'mtp-detect', and experience a similar crash.

Fwiw, this laptop has only a usb mouse connected, nothing else.  No devices I'd expect libmtp to detect and try to probe in particular.

How to reproduce
-----
[rdieter1@localhost ~]$ mtp-detect
libmtp version: 1.0.5

Listing raw device(s)
Device 0 (VID=0b97 and PID=7762) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
Device 1 (VID=045e and PID=0040) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
   Found 2 device(s):
   0b97:7762 @ bus 2, dev 4
   045e:0040 @ bus 5, dev 2
Attempting to connect device(s)
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
Segmentation fault (core dumped)
Comment 1 Rex Dieter 2011-03-11 08:05:25 EST
Created attachment 483712 [details]
File: backtrace
Comment 2 Rex Dieter 2011-04-01 08:12:17 EDT

*** This bug has been marked as a duplicate of bug 684214 ***

Note You need to log in before you can comment on or make changes to this bug.