Bug 684214 - [abrt] libmtp-examples-1.0.5-2.fc15: op_reset_device: Process /usr/bin/mtp-detect was killed by signal 11 (SIGSEGV)
[abrt] libmtp-examples-1.0.5-2.fc15: op_reset_device: Process /usr/bin/mtp-de...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
abrt_hash:14cf324619ccdfbbee816caa6b9...
:
: 684205 (view as bug list)
Depends On:
Blocks: F15Blocker/F15FinalBlocker F15Beta-accepted/F15BetaFreezeExcept F15Blocker-kde 682916 684208
  Show dependency treegraph
 
Reported: 2011-03-11 08:53 EST by Rex Dieter
Modified: 2011-04-15 17:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: libmtp-1.0.6-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-15 17:20:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.14 KB, text/plain)
2011-03-11 08:53 EST, Rex Dieter
no flags Details

  None (edit)
Description Rex Dieter 2011-03-11 08:53:32 EST
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 5263 bytes
cmdline: mtp-detect
component: libmtp
Attached file: coredump, 634880 bytes
crash_function: op_reset_device
executable: /usr/bin/mtp-detect
kernel: 2.6.38-0.rc8.git0.1.fc15.x86_64
package: libmtp-examples-1.0.5-2.fc15
rating: 4
reason: Process /usr/bin/mtp-detect was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
How to reproduce: run mtp-detect
time: 1299851557
uid: 500
Comment 1 Rex Dieter 2011-03-11 08:53:33 EST
Created attachment 483723 [details]
File: backtrace
Comment 2 Rex Dieter 2011-03-11 08:54:19 EST
This should be a better backtrace than bug #684205
Comment 3 Linus Walleij 2011-03-31 18:14:05 EDT
Can you test this with libmtp 1.0.6-1 which should be in Rawhide now?
Comment 4 Rex Dieter 2011-04-01 08:11:44 EDT
1.0.6-2 looks like a winner.

$ mtp-detect
libmtp version: 1.0.6

Listing raw device(s)
   No raw devices found.


and amarok now launches ok too.
Comment 5 Rex Dieter 2011-04-01 08:12:17 EDT
*** Bug 684205 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2011-04-01 08:15:03 EDT
nominating for f15-beta , would be nice if some of our default apps shipped (rhythmbox and amarok) didn't crash out of the box on our live images.
Comment 7 Adam Williamson 2011-04-01 13:57:32 EDT
To have this fixed for F15 Beta it needs to be submitted as an update via Bodhi. Linus, can you do that? Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Tim Flink 2011-04-01 14:03:20 EDT
Discussed at the 2011-04-01 blocker bug review meeting. We agreed that while this does not fall under any of the beta release criteria, it does fall under the final release criteria "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use."

Rejected as beta blocker, accepted as beta nth, accepted as final blocker.
Comment 9 Adam Williamson 2011-04-05 00:32:48 EDT
Rex: if Linus isn't around to submit the updated libmtp as an update, you could do it - Bodhi allows you to submit other people's packages as updates, I've done it before...
Comment 10 Fedora Update System 2011-04-05 19:55:05 EDT
libmtp-1.0.6-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libmtp-1.0.6-2.fc15
Comment 11 Fedora Update System 2011-04-06 22:20:30 EDT
Package libmtp-1.0.6-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libmtp-1.0.6-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libmtp-1.0.6-2.fc15
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2011-04-15 17:20:07 EDT
libmtp-1.0.6-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.