Bug 68449 - icons overlapped on gnome desktop when running gnome from remote X terminal
Summary: icons overlapped on gnome desktop when running gnome from remote X terminal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 70482 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-10 10:51 UTC by Pavel
Modified: 2007-04-18 16:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 17:10:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel 2002-07-10 10:51:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020709

Description of problem:
When running gnome environment from remote terminal, the icons (home directory,
trash, start here) are placed on top of each other in upper eft corner of the
desktop. When running session from local display icons positioned normally.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in from remote system (e.g running "X -query IP" from remote computer
using gnome session

	

Actual Results:  Icons placed on top of each other

Expected Results:  Place icons normally

Additional info:

Right-click on the desktop and selecting "Clean up by name" places the icons
properly, but on next login they are still overlapped.

Comment 1 Havoc Pennington 2002-07-15 04:48:35 UTC
This seems to be some sort of race condition that happens when things are slow.

Comment 2 Alexander Larsson 2002-07-15 08:13:50 UTC
I've seen this when starting locally too. It doesn't happen often, but it
happens. Seems like it looses metadata somehow. Or maybe it doesn't relayout
when it finishes reading the metadata.


Comment 3 Pavel 2002-07-15 08:16:40 UTC
Never seen it in local session, but from remote terminal it happens always.

Comment 4 Alexander Larsson 2002-07-15 12:42:16 UTC
I got it just now, and i tried to go to ~/.gnome-desktop and turn on manual
layout in a window. The window got the right icon placement, so it seems the
metadata is not actually lost, just not applied to the desktop.


Comment 5 Alan Cox 2002-07-15 13:33:06 UTC
Telsa saw this on a local session (slow machine, VESA server)


Comment 6 Fred New 2002-07-31 07:02:01 UTC
I'm seeing this a lot on my Pentium 75 test machine with an ATI Mach64 VT 
(264VT) PCI adapter under Limbo 2.  The "Clean Up by Name" is often remembered 
in the next session, but it is also forgotten a lot, too.

Comment 7 Luke 2002-07-31 17:10:24 UTC
I had this too on a P133 with S3 virge video. Local install.  I was able to
eventually get them to be instacked.  Initially I moved them and they would go
right back up to upper left corner.

Comment 8 Alexander Larsson 2002-08-20 08:34:16 UTC
This is fixed in  2.0.4-2

Comment 9 Alexander Larsson 2002-08-30 12:31:44 UTC
*** Bug 70482 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.