Bug 684982 - [RV635] Fedora 15 xorg uses internal lvds panel as primary display when laptop lid is closed
[RV635] Fedora 15 xorg uses internal lvds panel as primary display when lapto...
Status: CLOSED DUPLICATE of bug 531318
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-14 18:25 EDT by Pasi Karkkainen
Modified: 2011-03-22 08:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-22 08:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
f15-alpha-livecd-dmesg (124.21 KB, text/plain)
2011-03-20 15:30 EDT, Pasi Karkkainen
no flags Details
f15-alpha-livecd-messages (229.30 KB, text/plain)
2011-03-20 15:31 EDT, Pasi Karkkainen
no flags Details
f15-alpha-livecd-Xorg.0.log (52.61 KB, text/plain)
2011-03-20 15:31 EDT, Pasi Karkkainen
no flags Details

  None (edit)
Description Pasi Karkkainen 2011-03-14 18:25:22 EDT
Description of problem:

I have HP EliteBook 8530p laptop with ATI/Radeon graphics. When the laptop is in the docking station, laptop lid closed, and I start Fedora 15 (tested with Alpha release live CD) the internal laptop lvds panel is used as the primary display, ie. the gnome desktop appears on the internal lvds panel under the closed lid, and not on the external DVI display that *should* be used in the case when laptop lid is closed.

Version-Release number of selected component (if applicable):
Fedora 15 Alpha x86_64 LIVE CD.

How reproducible:
Always.

Steps to Reproduce:
1. Connect laptop to the docking station.
2. Close laptop lid and connect the external DVI display.
3. Power-on the laptop and boot into Fedora 15.
  
Actual results:
Internal LVDS panel under the closed lid is used as the primary display.

Expected results:
Only the external DVI display should be used because laptop lid is closed.

Additional info:
ACPI lid status works OK on this laptop, so you can see the actual lid state from /sys.
Comment 1 Matěj Cepl 2011-03-15 13:57:44 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Pasi Karkkainen 2011-03-15 14:36:36 EDT
Ok, I'll attach the logs later today.

I think the problem is that there's no component in xorg or in Fedora that monitors ACPI lid state and does actions based on it.. at least not as a default.

Internal LVDS is always reported as 'connected' by drm/kernel, since it is, so one needs to monitor the ACPI lid state to determine if the lid is open or closed.

This issue has been discussed earlier in many different bugzillas, see for example: https://bugzilla.redhat.com/show_bug.cgi?id=595644 .
Comment 3 Matěj Cepl 2011-03-17 05:02:02 EDT
And does a workaround from bug 595644 comment 19 work for you?
Comment 4 Pasi Karkkainen 2011-03-17 05:08:41 EDT
(In reply to comment #3)
> And does a workaround from bug 595644 comment 19 work for you?

That workaround does work on F14, but I haven't tried with F15 Alpha yet. I assume it will help with F15 aswell.

But that workaround doesn't really help with the *actual* problem, which is: The Fedora installer DVD and LiveCD don't work out-of-the-box !

You can't tweak those settings for the LiveCD .. or if you change them, they're gone in the next reboot.

I'd like Fedora to work OK out-of-the-box.
Comment 5 Matěj Cepl 2011-03-17 19:17:16 EDT
OK, please, attach those logs. No, I haven't suggested that the workaround is solution we would accept and close this bug, it really should work out of the box.
Comment 7 Pasi Karkkainen 2011-03-20 15:30:30 EDT
Created attachment 486499 [details]
f15-alpha-livecd-dmesg
Comment 8 Pasi Karkkainen 2011-03-20 15:31:05 EDT
Created attachment 486500 [details]
f15-alpha-livecd-messages
Comment 9 Pasi Karkkainen 2011-03-20 15:31:25 EDT
Created attachment 486501 [details]
f15-alpha-livecd-Xorg.0.log
Comment 10 Pasi Karkkainen 2011-03-20 15:33:07 EDT
Attachments added. No Xorg cfgfile since this is from F15 Alpha LiveCD session.
Comment 11 Matěj Cepl 2011-03-22 08:10:56 EDT
Yes, we have problems with distinguishing different types of displays. Closing as duplicate of bug 531318.

*** This bug has been marked as a duplicate of bug 531318 ***

Note You need to log in before you can comment on or make changes to this bug.