Bug 531318 - (wrong_display) we are confused about what's monitor and what's LCD display
we are confused about what's monitor and what's LCD display
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
: 680325 684982 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-27 13:54 EDT by jmccann
Modified: 2015-01-14 18:23 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 17:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jmccann 2009-10-27 13:54:32 EDT
When I start my laptop when it is in the dock with an external LCD attached it comes up with dual monitors configured.  It should probably not be displaying things I can't see on the closed internal.  Also, when I open the lid the outputs change and the displays are cloned.

Here is some information while at the GDM screen:

type:                    Lid Switch
state:      closed

Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 8192 x 8192
LVDS1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050      60.0*+   50.0  
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1680x1050+1680+0 (normal left inverted right x axis y axis) 433mm x 270mm
   1680x1050      60.0*+
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
DVI1 disconnected (normal left inverted right x axis y axis)
Comment 1 Matěj Cepl 2009-11-05 12:19:29 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 2 jmccann 2009-11-08 16:53:44 EST
Ajax had a build that I confirmed to fix this.  Not sure where that is now.
Comment 3 Matěj Cepl 2009-11-08 19:28:31 EST
OK, putting NEEDINFO for you to find it :)
Comment 4 Bug Zapper 2009-11-16 09:26:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 jmccann 2009-11-19 11:30:13 EST
Ajax, is this something we can put in an update for f12?
Comment 6 Jeff Bastian 2010-03-12 10:12:31 EST
I've had this problem too, but yesterday I booted my Lenovo T60 in the docking station with the lid closed and it used the external monitor correctly.  The xorg-x11-drv-intel RPM hasn't been updated since 18 Nov 2009 so I'm not sure what fixed it.  Maybe it was the recent update to KDE 4.4.0?
Comment 7 Andreas Fleig 2010-06-05 22:02:54 EDT
I'm experiencing this bug in F13.

I regularly use my R61 with a docking station. There are multiple issues:

- When I close the lid, and an external screen is attached, the session is locked
  Expected behaviour: 
  - X should turn off LVDS
  - If another screen is attached, it should be turned on at it's native/
    max resolution
  - The session should only be locked if there's no external screen attached

- When starting X, screens are cloned, even if the lid is closed
Comment 8 Jeff Bastian 2010-07-08 10:29:05 EDT
This problem was fixed for me as I mentioned in comment 6, but after upgrading to Fedora 13 it has returned.

My T60 is in the docking station with the lid closed when I turn it on.  At first, everything displays fine on the external monitor: BIOS/POST, grub, plymouth graphical boot, gdm, and even the KDE splash screen.  But as soon as KDE is fully launched, everything moves over to the laptop display (which is still closed) and I'm left with a mostly blank screen.

My current workaround is to right-click on the desktop to open a terminal and run
   xrandr --fb 1920x1080 --output LVDS1 --off --output VGA1 --mode 1920x1080

I've also tried Gnome and XFCE and they both have the same problem so I don't believe this is a KDE bug.

I'm updating the version on this bug to 13.
Comment 9 Jeff Bastian 2011-01-04 18:09:20 EST
I'm now using a Lenovo T510 with Fedora 14 and this is still a bug.  It still tries to use the closed lid display.
Comment 10 Matěj Cepl 2011-03-17 07:33:13 EDT
*** Bug 680325 has been marked as a duplicate of this bug. ***
Comment 11 Matěj Cepl 2011-03-22 08:10:56 EDT
*** Bug 684982 has been marked as a duplicate of this bug. ***
Comment 12 Fedora End Of Life 2012-08-16 17:44:31 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.