Bug 68546 - redhat-config-network keeps crashing when saving settings
redhat-config-network keeps crashing when saving settings
Status: CLOSED DUPLICATE of bug 65073
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i586 Linux
high Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-10 22:21 EDT by schnuff
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 22:21:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description schnuff 2002-07-10 22:21:04 EDT
Description of Problem:

as soon as i try to save my network-settings, i get the following message:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 458, in on_okButton_clicked
    if self.save() != 0:
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__[selfkey])
KeyError: options


Version-Release number of selected component (if applicable):
included in redhat 7.3


How Reproducible:
always

Steps to Reproduce:
1. start redhat-config-network (command 'neat') as root
2. edit settings for network-adapter, hosts, etc
3. either try to apply settings, or close the window and let it save the settings

Actual Results:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 458, in on_okButton_clicked
    if self.save() != 0:
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__[selfkey])
KeyError: options

Expected Results:
well, all it should do is, save the settings in the appropriate files

Additional Information:

using an rtl8019-network-card (isa, ne200-compatible), irq 9, io 0x240
net: 192.168.0.0
subnet: 255.255.255.0
Comment 1 Harald Hoyer 2002-07-11 04:43:24 EDT

*** This bug has been marked as a duplicate of 65073 ***

Note You need to log in before you can comment on or make changes to this bug.