Bug 68637 - Installer crashes immediately following format of / partition while using the GUI installer.
Installer crashes immediately following format of / partition while using the...
Status: CLOSED DUPLICATE of bug 68718
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-11 18:15 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 21:40:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file (69.64 KB, text/plain)
2002-07-11 18:19 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-11 18:15:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I can complete the install of the product up to the point of formatting the 
first hard drive, then the install crashes. I have attached the crash logs for 
both install attempts using the ext2 and ext3 file systems. It is important to 
note that this problem does not occur using the text based install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot with iso image CD.
2.Input all required information.
3.Complete the formatting of the drive(s).
	

Actual Results:  The installer produced an error message that was immediately 
identified as a bug in anaconda by the operating system.

Expected Results:  The install image should have been transferred to the hard 
disk.

Additional info:

I will list the machine configuration here:
HP Kayak
PII 400 MHZ
256 MB RAM
AIC 7880 SCSI Controller Card ID #7
3 Hard Drives
1 Seagate ST34502LW 4.2 GB Hard Drive SCSI ID #0
2 IBM DCAS-34330 4.2 GB Hard Drives SCSI IDs #3 and #4
Matrox G400 Dual Head Video Card
3 button mouse
Partitions:
SDA1 512 MB (swap), SDA2 75 MB (/boot), SDA3 filled disk (/)
custom install
english language
lilo boot loader at MBR
DHCP
No firewall
NO smb, nis, ldap, or kereberos setup
no lba 32
i can provide the package listing if you need (I have probably given you too 
much anyway :))
Comment 1 Need Real Name 2002-07-11 18:19:33 EDT
Created attachment 65004 [details]
anaconda dump file
Comment 2 Need Real Name 2002-07-16 21:40:16 EDT
Alright, an update to this issue. I have found what may be the issue here. The 
way I had the box listed above formatted was as such:
sda:
512MB Swap, 75MB /boot, the remainder of the drive as /. All partitions marked 
to be formatted.
sdb:
Entire drive was fdisked to be fd (Linux Raid Autodetect). Not formatted. 
sdc:
Entire drive was fdisked to be fd (Linux Raid Autodetect). Not formatted.

I went back and tried the install again, except this time, I selected the 
drives to be autopartitioned. I put a 512MB swap on all three both drives, and 
the remainder of sdb, and sdc became /home and /var respectively (I manually 
chose those). The partitions all formatted, and VOILA! The install image 
succesfully transfered to the drive and the remainder of the install went 
without a hitch. I have since repeated the process (with multiple partitioning 
scenarios on sdb and sdc) and have so far had a 100% success rate. My question 
is this, I have always done my Linux servers the way I listed in my previous 
post, and have had no problems (the last version I had on this particular 
server was 7.2). What has changed since then, if anything? From the untrained 
eye, emphasis on the word untrained, it looks like the installer is trying to 
transfer the image to the volume with the largest amount of free space, and 
not the volume with the largest amount of formatted free space. I'm sure I'm 
totally off base and on crack, but I thought I'd throw that out there.:)
Comment 3 Jeremy Katz 2002-07-18 02:11:25 EDT

*** This bug has been marked as a duplicate of 68718 ***

Note You need to log in before you can comment on or make changes to this bug.