Bug 68718 - installer crashed if formating existing installation
installer crashed if formating existing installation
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 68000 68491 68637 68810 68864 68918 69330 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-12 16:09 EDT by Calvin Austin
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 17:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Calvin Austin 2002-07-12 16:09:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
The installer only works for me if I do not ask anaconda to reformat existing
partitions. using the option to not reformat using fdisk
works

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose to install with fdisk, choose an existing partition and 
ask limbo to format the partition (default)
2.installer crashes when starting to install when it wants to format the disk
3.
	

Actual Results:  anaconda dump, reboot, top of anaconda output below

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 682, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 148, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 549, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 149, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 214, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 396, in turnOnFilesystems
    thefsset.makeFilesystems (instPath)
  File "/usr/lib/anaconda/fsset.py", line 1119, in makeFilesystems
    self.formatEntry(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 1046, in formatEntry
    entry.fsystem.formatDevice(entry, self.progressWindow, chroot)
  File "/usr/lib/anaconda/fsset.py", line 493, in formatDevice
    entry.mountpoint)
  File "/usr/lib/anaconda/fsset.py", line 2033, in ext2FormatFilesystem
    if os.WIFEXITED(status) and (os.WEXITSTATUS(status) == 0):
UnboundLocalError: local variable 'status' referenced before assignment
Comment 1 Jeremy Katz 2002-07-17 00:18:18 EDT
*** Bug 68918 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2002-07-17 23:20:36 EDT
*** Bug 68810 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2002-07-18 01:52:41 EDT
*** Bug 68491 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-07-18 01:56:18 EDT
*** Bug 68000 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2002-07-18 02:06:09 EDT
*** Bug 68864 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-07-18 02:11:21 EDT
*** Bug 68637 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2002-07-23 12:38:38 EDT
*** Bug 69330 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2002-07-31 17:12:44 EDT
We're handling this exception differently now which appears to help.
Comment 9 Jay Turner 2002-09-05 09:17:49 EDT
Fix confirmed with re0904.1 tree.

Note You need to log in before you can comment on or make changes to this bug.