Bug 68656 - Mouse Becomes Nonfunctional In Sony Vaio Laptop Installs If 2 Pointing Devices Installed
Mouse Becomes Nonfunctional In Sony Vaio Laptop Installs If 2 Pointing Device...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-12 00:02 EDT by Bob Cochran
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-06 00:47:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XF86Config file generated by Anaconda when Limbo installed. (3.64 KB, text/plain)
2002-07-12 23:29 EDT, Bob Cochran
no flags Details
from /etc/sysconfig/mouse (89 bytes, text/plain)
2002-07-12 23:31 EDT, Bob Cochran
no flags Details
/etc/X11/XF86Config file which currently allows me to use the 3-button mouse. (3.85 KB, text/plain)
2002-07-12 23:32 EDT, Bob Cochran
no flags Details

  None (edit)
Description Bob Cochran 2002-07-12 00:02:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When installing Limbo to a Sony Vaio PCG-F350 laptop computer which has both a
Microsoft 3-button Mouse connected to the PS/2 port and the OEM touchpad mouse
(the ALPS Glidepoint), the mouse becomes nonfunctional. If you touch the
Microsoft Mouse to move the mouse pointer, the mouse arrow "goes crazy" and
disappears to the top or top right edge of the laptop's  display. It will zoom
across the top edge of the display if you move the mouse, then "park" in the top
right edge of the display where it is barely visible and becomes totally unusable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Limbo to Sony Vaio PCG-F350 computer which has a 3-button Microsoft
Mouse connected to the PS/2 port. This model of Vaio also has an ALPS Glidepoint
touchpad mouse.
2.At the first graphical screen attempt to move the mouse arrow using the
Microsoft Mouse.
3.The mouse arrow immediately behaves as described above.
	

Actual Results:  The mouse arrow is rendered unusable. The Microsoft Mouse
cannot be used as a pointing device and one cannot click with it. The mouse
arrow cannot be manipulated with the ALPS Glidepoint touchpad, either.

Expected Results:  One of the two pointing devices on the laptop should have
been usable.

Additional info:

I've always felt that Anaconda should prompt the user for which pointing device
it should "pay attention to" on a laptop system.An even better approach is to do
a hardware probe on the PS/2 or USB ports or otherwise check the existing
installed operating system, if any, to determine which pointing device seems to
be preferred by the user. For example, it can't be that hard to inspect
/etc/X11/XF86Config-4 in an existing Red Hat System to determine what the
corepointer is. Or just hardware probe to see if a "real" mouse is connected to
the laptop.
Comment 1 Warren Togami 2002-07-12 08:06:25 EDT
Is that a wheel mouse?

Do both mice work properly if you change the mouse driver to two button PS/2?
Comment 2 Bob Cochran 2002-07-12 18:03:21 EDT
Yes there is a wheel between the left and right Microsoft mouse buttons. Let me
check into the 2-button mouse assignment and report back. Thanks!
Comment 3 Bob Cochran 2002-07-12 23:29:49 EDT
Created attachment 65204 [details]
XF86Config file generated by Anaconda when Limbo installed.
Comment 4 Bob Cochran 2002-07-12 23:31:19 EDT
Created attachment 65205 [details]
from /etc/sysconfig/mouse
Comment 5 Bob Cochran 2002-07-12 23:32:41 EDT
Created attachment 65206 [details]
/etc/X11/XF86Config file which currently allows me to use the 3-button mouse.
Comment 6 Bob Cochran 2002-07-12 23:34:50 EDT
How do I tell XF86Config that I want a 2-button PS/2 driver so I can answer
Warren's question? I'll try to research this more. In the mean time I would like
to attach some files. The first one is XF86Config.original. This is the original
XF86Config file generated by Anaconda when I installed Limbo on this machine.
The second file is mouse. It was copied from /etc/sysconfig/mouse on this
machine. The 3rd file is XF86Config.works. This is the XF86Config file that
allows me to use the 3-button Microsoft Mouse. This file actually has it's
origins in the Skipjack beta when I couldn't get the mouse to work under KDE on
Skipjack either. I posted a query to Skipjack-list and someone else with a
similar machine suggested I use the parameters you see here.
Comment 7 Warren Togami 2002-07-13 00:03:57 EDT
Try backing up your XF86Config file, then run mouseconfig.  That will allow you
to choose your mouse driver.
Comment 8 Bob Cochran 2002-07-13 00:40:51 EDT
Thanks for pointing me to mouseconfig. I did as suggested, selecting
"GenericPS/2" with the "Emulate 3 buttons" option turned on. This change didn't
update XF86Config (I diffed it against the backup to be sure there were no
changes). It updated /etc/sysconfig/mouse, apparently. Perhaps other files as
well? Anyhow I restarted the machine because I'm also having a problem with X
taking a really long time to come up. It sometimes displays a gray screen with
no windows and a mouse pointer in the shape of an X, and stays frozen in that
state until, apparently, I move the Microsoft Mouse.

After running mouseconfig and restarting, the screen went gray...then turned
black...then turned gray again and flickered briefly...then the KDE login screen
finally came up. I attempted to use the laptop's touchpad at this point, to move
the insertion point to the "password" line in the login window. As soon as the
mouse arrow got near any edge of the login window, it shot back to the bottom of
the display screen. I could move the arrow around with the touchpad but couldn't
use it within the login window. I had full use of the Microsoft Mouse, however,
and could move the insertion point..click...etc.

By the way, mouseconfig has a really awful looking appearance. The fonts are
just terrible and lines of text don't display clearly. 

Also, I had earlier used redhat-config-mouse and it crashed with python errors.
I'm too tired to post bugs at this point, but will check into it tomorrow.
Comment 9 Michael Fulbright 2002-08-14 12:25:05 EDT
If I understand this correctly - you have two ps/2 mouse devices and they both
need to use IMP/2 instead of PS/2 as the protocol?
Comment 10 Warren Togami 2002-08-14 12:44:11 EDT
Nope... that's what I thought too, until a fresh re-install of Limbo2 where I
chose "Generic 2-Button Mouse PS2, emulate 3".  Now it seems to be properly
using PS/2 + emulate 3 on my touchpad (IMPS/2 *doesn't work for the touchpad
normally), while automatically adding the USB IMPS/2 mouse that works great
dynamically hotplugging just like it should in XFree86 4.2.0.

I have a Sony Vaio FXA36 Athlon laptop with its PS/2 2-button touchpad, and a
Logitech USB wheel mouse.

I remember mouseconfig was unable to change the XF86Config file to this config
the last time I installed Limbo2 where I chose USB mouse.  That time the PS/2
touchpad completely disabled itself, and no amount of fiddling with
redhat-config-xfree86 --reconfig or mouseconfig would bring it back.

Does only Anaconda implicitly add the USB mouse by default like the
RELEASE-NOTES says it should, and not redhat-config-xfree86 --reconfig or
mousconfig?
Comment 11 Michael Fulbright 2002-08-23 12:00:13 EDT
Glad to hear anaconda is working.

I'll reassign to redhat-config-xfree86 to answer your last question.
Comment 12 Alexander Larsson 2002-08-26 12:26:01 EDT
redhat-config-xfree86 --reconfig does add a usb mouse with AlwaysCore, unless
the main mouse is usb. 

I'm not sure what else I'm supposed to comment on in this bug?
Comment 13 Brent Fox 2003-01-06 14:02:11 EST
Warren, do you consider this issue fixed?  I'm not quite sure what the next step
is here?
Comment 14 Warren Togami 2003-01-06 16:17:16 EST
I *think* this was working properly in RH8.0 for additional USB mice, but with
Bug 80359 I can't test it properly in Phoebe.

I think cochranb's original issue was with an additional PS/2 mouse instead, and
the wrong PS/2 mouse protocol being chosen.  He would have to comment on whether
this is fixed in Phoebe or not (although watch out for Bug 80309 before testing.)
Comment 15 Brent Fox 2003-02-06 00:47:50 EST
Well, I guess if we haven't heard from cochranb by this point, I'm guessing that
he hasn't had time to test with Phoebe.  The two bugs that you pointed to in
your last post have since been fixed.

I'm going to close this report as 'Rawhide' at this point.  I don't have a Sony
VAIO to test it myself, unfortunately.  Anybody feel free to reopen this report
if there are still problems with mice on VAIO systems.

Note You need to log in before you can comment on or make changes to this bug.