Bug 687292 - [abrt] clang-2.8-5.fc14: Process /usr/bin/clang was killed by signal 11 (SIGSEGV)
[abrt] clang-2.8-5.fc14: Process /usr/bin/clang was killed by signal 11 (SIGS...
Status: CLOSED DUPLICATE of bug 694896
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
abrt_hash:7928d4cb14f07d7c087bcd0bbc9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-15 10:57 EDT by Gen Zhang
Modified: 2011-08-02 18:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 18:13:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (19.41 KB, text/plain)
2011-03-15 10:57 EDT, Gen Zhang
no flags Details

  None (edit)
Description Gen Zhang 2011-03-15 10:57:25 EDT
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 19871 bytes
cmdline: /usr/bin/clang -cc1 -triple x86_64-redhat-linux-gnu -S -disable-free -disable-llvm-verifier -main-file-name q-voter-3d.cpp -mrelocation-model static -mdisable-fp-elim -mconstructor-aliases -munwind-tables -target-cpu x86-64 -target-linker-version 2.20.51.0.7 -resource-dir /usr/lib/clang/2.8 -std=c++0x -ferror-limit 19 -fmessage-length 80 -fexceptions -fgnu-runtime -fdiagnostics-show-option -fcolor-diagnostics -o /tmp/cc-vAnjic.s -x c++ q-voter-3d.cpp
component: llvm
Attached file: coredump, 16998400 bytes
crash_function: clang::ASTContext::getCanonicalType(clang::QualType)
executable: /usr/bin/clang
kernel: 2.6.35.11-83.fc14.x86_64
package: clang-2.8-5.fc14
rating: 4
reason: Process /usr/bin/clang was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1300200841
uid: 500

How to reproduce
-----
1. Include <random> with clang++
Comment 1 Gen Zhang 2011-03-15 10:57:28 EDT
Created attachment 485313 [details]
File: backtrace
Comment 2 Michel Alexandre Salim 2011-03-17 12:25:25 EDT
clang 2.8 does not have complete support for c++0x; however, the -5 release we did does have a problem in which the 'bits' includes are not accessible by clang++. The -9 update will fix that.

I sometimes get a crash and sometimes just an error message with clang-2.8-9, of this sort:


$ clang++ test2.cpp
In file included from test2.cpp:1:
In file included from /usr/include/c++/4.6.0/random:34:
/usr/include/c++/4.6.0/bits/c++0x_warning.h:32:2: error: #error This file
      requires compiler and library support for the upcoming ISO C++ standard,
      C++0x. This support is currently experimental, and must be enabled with
      the -std=c++0x or -std=gnu++0x compiler options.
#error This file requires compiler and library support for the upcoming \
 ^
1 error generated.

(and more errors if I pass -std=c++0x)

Do you always see a crash? Could you retest with 2.8-9 once it lands? Thanks.
Comment 3 Fedora Admin XMLRPC Client 2011-03-17 19:51:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Michel Alexandre Salim 2011-08-02 18:13:45 EDT

*** This bug has been marked as a duplicate of bug 694896 ***

Note You need to log in before you can comment on or make changes to this bug.