This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 694896 - C++ compilation fails with "unexpected type name"
C++ compilation fails with "unexpected type name"
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
: 675622 687292 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-08 15:09 EDT by Rob Riggs
Modified: 2011-08-02 18:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 18:10:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Riggs 2011-04-08 15:09:12 EDT
Description of problem:
clang-2.8 and clang-2.9 are incompatible with GCC 4.6.  The problem is documented here: http://llvm.org/bugs/show_bug.cgi?id=9472


Version-Release number of selected component (if applicable):
clang-2.8-10.fc15.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. echo "#include <algorithm>" | clang++ -x c++ -c -

See link to llvm bug above.  Any code that includes <algorithm> fails to compile.
  
Actual results:
Compilation fails with "unexpected type name" error.

Expected results:
A working executable as under Fedora 13.

Additional info:
This is a known incompatibility between clang++ up to 2.9 and GCC 4.6.
Comment 1 Michel Alexandre Salim 2011-08-02 18:13:07 EDT
*** Bug 675622 has been marked as a duplicate of this bug. ***
Comment 2 Michel Alexandre Salim 2011-08-02 18:13:45 EDT
*** Bug 687292 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.