Bug 687956 - RHEL6.1-Beta DVD: unable to read repositories
Summary: RHEL6.1-Beta DVD: unable to read repositories
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev
Version: 6.1
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 645474 670159
TreeView+ depends on / blocked
 
Reported: 2011-03-15 20:14 UTC by Russ Anderson
Modified: 2013-04-05 07:59 UTC (History)
10 users (show)

Fixed In Version: udev-147-2.35.el6
Doc Type: Bug Fix
Doc Text:
Some virtual machines do not properly implement the "READ TOC" SCSI command. This causes the Red Hat Enterprise Installer not to recognize the DVD medium properly. A workaround in cdrom_id, which is part of the udev package has been included in this update.
Clone Of:
Environment:
Last Closed: 2011-05-19 11:51:18 UTC


Attachments (Terms of Use)
Log files (49.70 KB, application/x-gzip)
2011-03-17 18:30 UTC, Russ Anderson
no flags Details
New log files with bz687956.img (62.29 KB, application/x-gzip)
2011-03-21 18:36 UTC, Russ Anderson
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0525 normal SHIPPED_LIVE udev bug fix and enhancement update 2011-05-19 09:37:42 UTC

Description Russ Anderson 2011-03-15 20:14:11 UTC
Description of problem:

With the RHEL6.1 iso (RHEL6.1-20110224.2-Server-x86_64-DVD1.iso) after formatting the hard drive the installer complains:

  Unable to read group information from repositories.
  This is a problem with the generation of your install tree.

This is using the default settings, letting the installer select the partition layout and use all of the hard drive.

To be extra annoying, the only choices are [Exit Installer] and [Retry], so
there is no way to go back and try different setting without resetting and 
starting all over.

The drive does get reformatted, but nothing gets installed on it.


Version-Release number of selected component (if applicable):

RHEL6.1-Alpha

How reproducible:

100%.

Steps to Reproduce:
1. On a SGI UV system, install from RHEL6.1-Alpha DVD.
2. Select new install, use all of hard drive.
3.
  
Actual results:

No install.

Expected results:

Install RHEL6.1-Alpha on the hard drive.

Additional info:

Tried to get the /tmp/*log files but was unable.  Ctl-alt-F2 got to the anaconda prompt but it would not accept input.

Comment 2 Russ Anderson 2011-03-15 20:34:42 UTC
Update CC list.

Comment 3 Ales Kozumplik 2011-03-16 15:28:22 UTC
Russ if the console is not working (which itself is strange) you can always have sshd started in the installation by adding 'sshd' to the kernel command line. Then you can ssh to the machine and scp out the log files.

Comment 4 Russ Anderson 2011-03-16 15:57:35 UTC
When I tried it again Ctl-alt-F2 got to the anaconda prompt successfully.  Not sure what the problem was the first time.  I could save the log files to a disk partition, but since the entire hard drive had just been repartitioned, there was no good install to boot to copy off the files.  

I'll try the sshd idea to scp the files to another machine.

FWIW, while at the anaconda prompt I verified it did have the DVD mounted and could ls the contents and see the repo directory.

Comment 5 Russ Anderson 2011-03-17 18:30:31 UTC
Created attachment 486081 [details]
Log files

Log files after the "Unable to read group information from repositories." error message.  

The output below shows the DVD mounted (on /mnt/stage2) and the repodata directory contents.

----------------------------------------------------------
-bash-4.1# mount
rootfs on / type rootfs (rw,relatime)
/proc on /proc type proc (rw,relatime)
/dev on /dev type tmpfs (rw,seclabel,relatime)
/dev/pts on /dev/pts type devpts (rw,seclabel,relatime,gid=5,mode=620,ptmxmode=000)
/sys on /sys type sysfs (rw,seclabel,relatime)
none on /tmp type tmpfs (rw,seclabel,relatime,size=256000k)
/dev/sr0 on /mnt/stage2 type iso9660 (ro,relatime)
/dev/loop0 on /mnt/runtime type squashfs (ro,relatime)
/selinux on /selinux type selinuxfs (rw,relatime)
/dev/mapper/vg_uv14sys-lv_root on /mnt/sysimage type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
/dev/sda2 on /mnt/sysimage/boot type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
/dev/sda1 on /mnt/sysimage/boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=cp437,iocharset=ascii,shortname=winnt,errors=remount-ro)
/dev on /mnt/sysimage/dev type tmpfs (rw,seclabel,relatime)
/dev/devpts on /mnt/sysimage/dev/pts type devpts (rw,seclabel,relatime,gid=5,mode=620,ptmxmode=000)
/dev/tmpfs on /mnt/sysimage/dev/shm type tmpfs (rw,seclabel,relatime)
/dev/mapper/vg_uv14sys-lv_home on /mnt/sysimage/home type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
/dev/proc on /mnt/sysimage/proc type proc (rw,relatime)
/dev/sysfs on /mnt/sysimage/sys type sysfs (rw,seclabel,relatime)
-bash-4.1# ls /mnt/stage2
EFI                       RELEASE-NOTES-bn-IN.html  RELEASE-NOTES-ja-JP.html  RELEASE-NOTES-ru-RU.html    ResilientStorage
EULA                      RELEASE-NOTES-de-DE.html  RELEASE-NOTES-kn-IN.html  RELEASE-NOTES-si-LK.html    ScalableFileSystem
GPL                       RELEASE-NOTES-en-US.html  RELEASE-NOTES-ko-KR.html  RELEASE-NOTES-ta-IN.html    Server
HighAvailability          RELEASE-NOTES-es-ES.html  RELEASE-NOTES-ml-IN.html  RELEASE-NOTES-te-IN.html    TRANS.TBL
LoadBalancer              RELEASE-NOTES-fr-FR.html  RELEASE-NOTES-mr-IN.html  RELEASE-NOTES-zh-CN.html    images
Packages                  RELEASE-NOTES-gu-IN.html  RELEASE-NOTES-or-IN.html  RELEASE-NOTES-zh-TW.html    isolinux
README                    RELEASE-NOTES-hi-IN.html  RELEASE-NOTES-pa-IN.html  RPM-GPG-KEY-redhat-beta     media.repo
RELEASE-NOTES-as-IN.html  RELEASE-NOTES-it-IT.html  RELEASE-NOTES-pt-BR.html  RPM-GPG-KEY-redhat-release  repodata
-bash-4.1# ls /mnt/stage2/repodata
04db477130c108351b7d213a92590b765b80626be43b5f3642e484d680a0e1f6-other.xml.gz
3fb7d149b1160d2b8e24a1f66f74f600f76b8910942f7f048b4273ba4355db2f-primary.sqlite.bz2
4a77521ad24caed306ce31404359abd971bd74bdbe0efb193e52e7b97fea0d67-comps-rhel6-Server.xml
98f0a764c8d2162e8d020f706ec9109b8a549177d030cafad5cb3300efbe049a-other.sqlite.bz2
TRANS.TBL
bef1e089b8f15ba9e8fabc674431bbd95ba1a366ec4680279224a0e0fafc0b8f-comps-rhel6-Server.xml.gz
c03c7e30f95f4f67b3167368fd627fa8cf7f4d20bacc02bb0420c53ddc299a26-filelists.sqlite.bz2
c24cefbb6779f9dac8b3cd2e3c33cec8290e5424a23d9df25393ef206ca96848-primary.xml.gz
dfb1f375746188b9a0e7eb307929283b450648c9329e55290de783c49cf45d60-filelists.xml.gz
productid
productid.gz
repomd.xml
-bash-4.1# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev                  16497840       212  16497628   1% /dev
none                    256000    134688    121312  53% /tmp
/dev/sr0               3461456   3461456         0 100% /mnt/stage2
/dev/loop0              131200    131200         0 100% /mnt/runtime
/dev/mapper/vg_uv14sys-lv_root
                      51606140    184196  48800504   1% /mnt/sysimage
/dev/sda2               495844     10513    459731   3% /mnt/sysimage/boot
/dev/sda1               204580         0    204580   0% /mnt/sysimage/boot/efi
/dev                  16497840       212  16497628   1% /mnt/sysimage/dev
/dev/tmpfs            16497840         0  16497840   0% /mnt/sysimage/dev/shm
/dev/mapper/vg_uv14sys-lv_home
                      54266324    184136  51325580   1% /mnt/sysimage/home
-bash-4.1#

Comment 7 Brian Lane 2011-03-17 19:48:36 UTC
I am not seeing this with the 20110315 image.

Comment 8 RHEL Product and Program Management 2011-03-18 12:49:24 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 9 Ales Kozumplik 2011-03-18 12:53:20 UTC
Patch awaiting review: https://www.redhat.com/archives/anaconda-devel-list/2011-March/msg00224.html

Note that this is not an attempt to fix the repo breakage in any way, this just correctly informs about the error and gets rid of the traceback.

Comment 10 Ales Kozumplik 2011-03-18 12:56:47 UTC
(In reply to comment #9)
> Patch awaiting review:
> https://www.redhat.com/archives/anaconda-devel-list/2011-March/msg00224.html
> 
> Note that this is not an attempt to fix the repo breakage in any way, this just
> correctly informs about the error and gets rid of the traceback.

scratch that, bad bugzilla.

Comment 11 Ales Kozumplik 2011-03-18 13:24:19 UTC
Reporter,

Can you please retest with updates=http://akozumpl.fedorapeople.org/bz687956.img added to the kernel command line (you will need to bring up the network too) and attach the new logfiles?

The update contains a new logging call that will hopefully give us a more specific information of what went wrong.

Comment 12 Russ Anderson 2011-03-18 13:52:20 UTC
I don't understand the request.  I am trying to install from the RHEL6.1-Alpha DVD.  How am I supposed to add a compressed python script to the kernel boot line?  Where does bz687956.img get copied to?  Thanks.

Comment 13 Ales Kozumplik 2011-03-18 14:08:42 UTC
I just want you to add the string "updates=http://akozumpl.fedorapeople.org/bz687956.img" to the kernel boot command line which you can edit on the dvd splash screen. This line is then parsed by the installer loader that determines this is an anaconda updates image, downloads it from the web, extracts it and runs the anaconda code there.

More information about this mechanism is here: http://fedoraproject.org/wiki/Anaconda/Updates

Comment 14 Russ Anderson 2011-03-18 14:26:15 UTC
Ah, now I understand.  Thanks.

Comment 15 Russ Anderson 2011-03-21 18:36:24 UTC
Created attachment 486667 [details]
New log files with bz687956.img

Attached are the log files with "updates=http://akozumpl.fedorapeople.org/bz687956.img" on the boot line.

Comment 16 David Cantrell 2011-03-21 20:37:13 UTC
I don't see any obvious errors in your log files.  bcl tried to reproduce this issue a while ago (comment #7) and couldn't.  Based on the relatively clean log files and bcl's findings, moving this to CLOSED WORKSFORME.  No one else is reporting repository reading issues either.

Give the beta release a try and if the problem continues, reopen the bug.

Comment 17 Russ Anderson 2011-03-21 21:04:10 UTC
> Based on the relatively clean log files and bcl's findings, moving
> this to CLOSED WORKSFORME. 

You're kidding, right?

> Give the beta release a try and if the problem continues, reopen the bug.

The Beta download just completed and it fails the same way.

Comment 18 Russ Anderson 2011-03-21 21:05:36 UTC
Updating summary to reflect Beta still broken.

Comment 19 Chris Lumens 2011-03-21 21:20:29 UTC
The problem is this in your storage.log:

13:29:39,270 DEBUG   : no type or existing type for sr0, bailing

which is caused by this udev information:

18:28:05,464 DEBUG   :             DeviceTree.addUdevDevice: info: {'ID_VENDOR_ID': '046b', 'ID_USB_INTERFACE_NUM': '00', 'ID_REVISION': '1.00', 'ID_MODEL_ID': 'ff92', 'ID_PATH': 'pci-0000:00:1a.7-usb-0:4:1.0-scsi-0:0:0:0', 'ID_VENDOR_ENC': 'AMI\\x20\\x20\\x20\\x20\\x20', 'ANACBIN': '/usr/sbin', 'ID_VENDOR': 'AMI', 'ID_SERIAL': 'AMI_Virtual_CDROM_serial-0:0', 'ACL_MANAGE': '1', 'ID_CDROM_MEDIA': '1', 'ID_CDROM_MEDIA_CD': '1', 'DEVTYPE': 'disk', 'ID_BUS': 'usb', 'MPATH_SBIN_PATH': '/usr/sbin', 'DEVLINKS': '/dev/block/11:0 /dev/scd0 /dev/disk/by-id/usb-AMI_Virtual_CDROM_serial-0:0 /dev/disk/by-path/pci-0000:00:1a.7-usb-0:4:1.0-scsi-0:0:0:0 /dev/cdrom', 'SUBSYSTEM': 'block', 'ID_CDROM': '1', 'ID_MODEL': 'Virtual_CDROM', 'ID_SERIAL_SHORT': 'serial', 'ID_USB_INTERFACES': ':080650:', 'ID_INSTANCE': '0:0', 'sysfs_path': '/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host1/target1:0:0/1:0:0:0/block/sr0', 'ID_TYPE': 'cd', 'MINOR': '0', 'symlinks': ['/dev/block/11:0', '/dev/scd0', '/dev/disk/by-id/usb-AMI_Virtual_CDROM_serial-0:0', '/dev/disk/by-path/pci-0000:00:1a.7-usb-0:4:1.0-scsi-0:0:0:0', '/dev/cdrom'], 'MAJOR': '11', 'name': 'sr0', 'DEVPATH': '/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host1/target1:0:0/1:0:0:0/block/sr0', 'UDEV_LOG': '3', 'DEVNAME': 'sr0', 'GENERATED': '1', 'ID_MODEL_ENC': 'Virtual\\x20CDROM\\x20\\x20\\x20', 'ID_USB_DRIVER': 'usb-storage'} ; name: sr0 ;

which does not contain an ID_FS_TYPE.  The reason no one else was able to reproduce this problem is because they're using a different DVD drive model/manufacturer, which evidently does not exhibit this problem.  Reassigning.

Comment 20 Russ Anderson 2011-03-21 21:31:32 UTC
> The reason no one else was able to reproduce this problem is because 
> they're using a different DVD drive model/manufacturer, which evidently
> does not exhibit this problem.  Reassigning.

Thanks for the analysis.  FWIW, RHEL6.0 DVD works on the same system.

Comment 21 Harald Hoyer 2011-03-23 13:14:29 UTC
What is the output of:

# /lib/udev/cdrom_id --debug /dev/sr0

With the udev of RHEL6.0 and if you can, with the udev version of RHEL6.1.

Comment 22 Harald Hoyer 2011-03-23 13:14:49 UTC
(In reply to comment #21)
> What is the output of:
> 
> # /lib/udev/cdrom_id --debug /dev/sr0
> 
> With the udev of RHEL6.0 and if you can, with the udev version of RHEL6.1.

of course with a "virtual" DVD inserted.

Comment 23 Russ Anderson 2011-03-24 04:29:42 UTC
Here is info for RHEL6.1-Beta.  Working on the RHEL6.0 data.

FWIW, the media test passes and the "virtual" DVD is mounted and readable.


----------------------------------------------------------------
-bash-4.1# /lib/udev/cdrom_id --debug /dev/sr0
main: probing: '/dev/sr0'
cd_inquiry: INQUIRY: [AMI     ][Virtual CDROM   ][1.00]
info_scsi_cmd_err: GET CONFIGURATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles: drive is pre-MMC2 and does not support 46h get configuration command
cd_profiles: trying to work around the problem
info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles_old_mmc: no current profile, but disc is present; assuming CD-ROM                                
cd_media_toc: READ TOC: len: 12, start track: 1, end track: 1
cd_media_toc: last track 1 starts at block 0
info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h                                   
ID_CDROM=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_CD=1                                                                                          
-bash-4.1# 
-bash-4.1# 
-bash-4.1# mount           
rootfs on / type rootfs (rw,relatime)
/proc on /proc type proc (rw,relatime)
/dev on /dev type tmpfs (rw,seclabel,relatime)                                                               
/dev/pts on /dev/pts type devpts (rw,seclabel,relatime,gid=5,mode=620,ptmxmode=000)
/sys on /sys type sysfs (rw,seclabel,relatime)
none on /tmp type tmpfs (rw,seclabel,relatime,size=256000k)
/dev/sr0 on /mnt/stage2 type iso9660 (ro,relatime)                                                           
/dev/loop0 on /mnt/runtime type squashfs (ro,relatime)
/selinux on /selinux type selinuxfs (rw,relatime)
/dev/mapper/vg_uv14sys-lv_root on /mnt/sysimage type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
/dev/sda2 on /mnt/sysimage/boot type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
/dev/sda1 on /mnt/sysimage/boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=cp437,iocharset=ascii,shortname=winnt,errors=remount-ro)
/dev on /mnt/sysimage/dev type tmpfs (rw,seclabel,relatime)
/dev/devpts on /mnt/sysimage/dev/pts type devpts (rw,seclabel,relatime,gid=5,mode=620,ptmxmode=000)
/dev/tmpfs on /mnt/sysimage/dev/shm type tmpfs (rw,seclabel,relatime)
/dev/mapper/vg_uv14sys-lv_home on /mnt/sysimage/home type ext4 (rw,seclabel,relatime,barrier=1,data=ordered)
/dev/proc on /mnt/sysimage/proc type proc (rw,relatime)
/dev/sysfs on /mnt/sysimage/sys type sysfs (rw,seclabel,relatime)
-bash-4.1# 
-bash-4.1# 
-bash-4.1# ls /mnt/stage2
EFI                       RELEASE-NOTES-en-US.html  RELEASE-NOTES-mr-IN.html  RPM-GPG-KEY-redhat-beta
EULA                      RELEASE-NOTES-es-ES.html  RELEASE-NOTES-or-IN.html  RPM-GPG-KEY-redhat-release
GPL                       RELEASE-NOTES-fr-FR.html  RELEASE-NOTES-pa-IN.html  ResilientStorage
HighAvailability          RELEASE-NOTES-gu-IN.html  RELEASE-NOTES-pt-BR.html  ScalableFileSystem
LoadBalancer              RELEASE-NOTES-hi-IN.html  RELEASE-NOTES-ru-RU.html  Server
Packages                  RELEASE-NOTES-it-IT.html  RELEASE-NOTES-si-LK.html  TRANS.TBL
README                    RELEASE-NOTES-ja-JP.html  RELEASE-NOTES-ta-IN.html  images
RELEASE-NOTES-as-IN.html  RELEASE-NOTES-kn-IN.html  RELEASE-NOTES-te-IN.html  isolinux
RELEASE-NOTES-bn-IN.html  RELEASE-NOTES-ko-KR.html  RELEASE-NOTES-zh-CN.html  media.repo
RELEASE-NOTES-de-DE.html  RELEASE-NOTES-ml-IN.html  RELEASE-NOTES-zh-TW.html  repodata
-bash-4.1#

Comment 24 Russ Anderson 2011-03-24 15:58:50 UTC
Data from RHEL6.0.

----------------------------------------------------------
-bash-4.1# /lib/udev/cdrom_id --debug /dev/sr0         
main: probing: '/dev/sr0'
cd_inquiry: INQUIRY: [AMI     ][Virtual CDROM   ][1.00]
cd_profiles: GET CONFIGURATION: number of profiles 4
cd_profiles: current profile 0x00
cd_profiles: no current profile, but CDS_DISC_OK, assuming incomplete implementation
cd_media_toc: READ TOC: len: 12
cd_media_toc: last track 1 starts at block 0
cd_media_info: disk type 00
ID_CDROM=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_CD=1
ID_CDROM_MEDIA_TRACK_COUNT_DATA=1
-bash-4.1#
----------------------------------------------------------

Comment 27 Harald Hoyer 2011-03-30 14:20:39 UTC
Please install this udev version
http://people.redhat.com/harald/downloads/udev/udev-147-2.35.el6/

and run 
# /lib/udev/cdrom_id --debug /dev/sr0

again.. could be on an already installed system, but with the virtual cdrom loaded with a medium.

Comment 28 Harald Hoyer 2011-03-30 14:33:56 UTC
BTW, the virtual CDROM implements the "READ TOC" SCSI command in a broken way.
It does not return details about the tracks on the CDROM.

Comment 29 Russ Anderson 2011-03-31 21:05:03 UTC
[root@uv14-sys ~]# rpm -U udev-147-2.35.el6.x86_64.rpm
[root@uv14-sys ~]# /lib/udev/cdrom_id --debug /dev/sr0
main: probing: '/dev/sr0'
cd_inquiry: INQUIRY: [AMI     ][Virtual CDROM   ][1.00]
info_scsi_cmd_err: GET CONFIGURATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles: drive is pre-MMC2 and does not support 46h get configuration command
cd_profiles: trying to work around the problem
info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles_old_mmc: no current profile, but disc is present; assuming CD-ROM
cd_media_toc: READ TOC: len: 12, start track: 1, end track: 1
cd_media_toc: last track 1 starts at block 0
info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
ID_CDROM=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_CD=1
ID_CDROM_MEDIA_TRACK_COUNT_DATA=1
[root@uv14-sys ~]# 


[root@uv14-sys ~]# mount /dev/sr0 /mnt/sr0
mount: block device /dev/sr0 is write-protected, mounting read-only
[root@uv14-sys ~]# ls /mnt/sr0
EFI                       RELEASE-NOTES-es-ES.html  RELEASE-NOTES-si-LK.html
EULA                      RELEASE-NOTES-fr-FR.html  RELEASE-NOTES-ta-IN.html
GPL                       RELEASE-NOTES-gu-IN.html  RELEASE-NOTES-te-IN.html
HighAvailability          RELEASE-NOTES-hi-IN.html  RELEASE-NOTES-zh-CN.html
images                    RELEASE-NOTES-it-IT.html  RELEASE-NOTES-zh-TW.html
isolinux                  RELEASE-NOTES-ja-JP.html  repodata
LoadBalancer              RELEASE-NOTES-kn-IN.html  ResilientStorage
media.repo                RELEASE-NOTES-ko-KR.html  RPM-GPG-KEY-redhat-beta
Packages                  RELEASE-NOTES-ml-IN.html  RPM-GPG-KEY-redhat-release
README                    RELEASE-NOTES-mr-IN.html  ScalableFileSystem
RELEASE-NOTES-as-IN.html  RELEASE-NOTES-or-IN.html  Server
RELEASE-NOTES-bn-IN.html  RELEASE-NOTES-pa-IN.html  TRANS.TBL
RELEASE-NOTES-de-DE.html  RELEASE-NOTES-pt-BR.html
RELEASE-NOTES-en-US.html  RELEASE-NOTES-ru-RU.html

Comment 30 Harald Hoyer 2011-04-01 07:48:19 UTC
(In reply to comment #29)
> [root@uv14-sys ~]# rpm -U udev-147-2.35.el6.x86_64.rpm
> [root@uv14-sys ~]# /lib/udev/cdrom_id --debug /dev/sr0
> main: probing: '/dev/sr0'
> cd_inquiry: INQUIRY: [AMI     ][Virtual CDROM   ][1.00]
> info_scsi_cmd_err: GET CONFIGURATION failed with SK=5h/ASC=20h/ACQ=00h
> cd_profiles: drive is pre-MMC2 and does not support 46h get configuration
> command
> cd_profiles: trying to work around the problem
> info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
> cd_profiles_old_mmc: no current profile, but disc is present; assuming CD-ROM
> cd_media_toc: READ TOC: len: 12, start track: 1, end track: 1
> cd_media_toc: last track 1 starts at block 0
> info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
> ID_CDROM=1
> ID_CDROM_MEDIA=1
> ID_CDROM_MEDIA_CD=1
> ID_CDROM_MEDIA_TRACK_COUNT_DATA=1

ok, fixed... what is the output of:

# udevadm info --query=all --name=/dev/sr0

Comment 31 Russ Anderson 2011-04-01 15:24:30 UTC
root@uv14-sys ~]# udevadm info --query=all --name=/dev/sr0 
P: /devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host1/target1:0:0/1:0:0:0/block/sr0
N: sr0
S: block/11:0
S: scd0
S: disk/by-id/usb-AMI_Virtual_CDROM_serial-0:0
S: disk/by-path/pci-0000:00:1a.7-usb-0:4:1.0-scsi-0:0:0:0
S: disk/by-label/RHEL_6.1\x20x86_64\x20Disc\x201
S: cdrom2
E: UDEV_LOG=3
E: DEVPATH=/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host1/target1:0:0/1:0:0:0/block/sr0
E: MAJOR=11
E: MINOR=0
E: DEVNAME=/dev/sr0
E: DEVTYPE=disk
E: SUBSYSTEM=block
E: ID_CDROM=1
E: ID_CDROM_MEDIA=1
E: ID_CDROM_MEDIA_CD=1
E: ID_CDROM_MEDIA_TRACK_COUNT_DATA=1
E: ID_VENDOR=AMI
E: ID_VENDOR_ENC=AMI\x20\x20\x20\x20\x20
E: ID_VENDOR_ID=046b
E: ID_MODEL=Virtual_CDROM
E: ID_MODEL_ENC=Virtual\x20CDROM\x20\x20\x20
E: ID_MODEL_ID=ff92
E: ID_REVISION=1.00
E: ID_SERIAL=AMI_Virtual_CDROM_serial-0:0
E: ID_SERIAL_SHORT=serial
E: ID_TYPE=cd
E: ID_INSTANCE=0:0
E: ID_BUS=usb
E: ID_USB_INTERFACES=:080650:
E: ID_USB_INTERFACE_NUM=00
E: ID_USB_DRIVER=usb-storage
E: ID_PATH=pci-0000:00:1a.7-usb-0:4:1.0-scsi-0:0:0:0
E: ID_FS_LABEL=RHEL_6.1_x86_64_Disc_1
E: ID_FS_LABEL_ENC=RHEL_6.1\x20x86_64\x20Disc\x201
E: ID_FS_TYPE=iso9660
E: ID_FS_USAGE=filesystem
E: ACL_MANAGE=1
E: GENERATED=1
E: UDISKS_PRESENTATION_NOPOLICY=0
E: DEVLINKS=/dev/block/11:0 /dev/scd0 /dev/disk/by-id/usb-AMI_Virtual_CDROM_serial-0:0 /dev/disk/by-path/pci-0000:00:1a.7-usb-0:4:1.0-scsi-0:0:0:0 /dev/disk/by-label/RHEL_6.1\x20x86_64\x20Disc\x201 /dev/cdrom2

Comment 32 Harald Hoyer 2011-04-01 15:40:05 UTC
(In reply to comment #31)
> E: ID_FS_TYPE=iso9660

All should be fine now with this udev bugfix/workaround

Comment 33 Russ Anderson 2011-04-12 16:05:26 UTC
Verified that RHEL6.1-20110411.n.0-Server-x86_64-DVD1.iso installs on SGI UV.

Thanks for the fix!

Comment 35 Harald Hoyer 2011-05-06 07:11:30 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Some virtual machines do not properly implement the "READ TOC" SCSI command. This causes the Red Hat Enterprise Installer not to recognize the DVD medium properly.
A workaround in cdrom_id, which is part of the udev package has been included in this update.

Comment 36 errata-xmlrpc 2011-05-19 11:51:18 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0525.html

Comment 37 Gong Nianshu 2011-07-22 09:46:08 UTC
Hi,

When I install RHEL6.1 using kickstart on Virtual Machine, this issue still existed.

ISO version: RHEL6.1-20110510.1-Server-x86_64-DVD1.iso.

I found this issue shall be fixed on RHEL6.1-20110411.n.0-Server-x86_64-DVD1.iso.

Thanks.

Comment 38 Salim Badakhchani 2013-04-04 17:51:06 UTC
Seeing this RHEL6.3 on Virtual Machine.

RHEL6.3-20120613.2-Server-x86_64-DVD1.iso

Comment 39 Harald Hoyer 2013-04-05 07:25:45 UTC
(In reply to comment #38)
> Seeing this RHEL6.3 on Virtual Machine.
> 
> RHEL6.3-20120613.2-Server-x86_64-DVD1.iso

Can you open a new bugzilla and provide the output of:

# /lib/udev/cdrom_id --debug /dev/sr0
# udevadm info --query=all --name=/dev/sr0

Comment 40 Salim Badakhchani 2013-04-05 07:59:29 UTC
See Bug 948713 - RHEL6.3 DVD: unable to read repositories


Note You need to log in before you can comment on or make changes to this bug.