Bug 688277 - /etc/mtab not a symlink on livecd
/etc/mtab not a symlink on livecd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
RejectedBlocker, AcceptedNTH
:
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-03-16 13:28 EDT by Oliver Henshaw
Modified: 2015-06-08 17:34 EDT (History)
8 users (show)

See Also:
Fixed In Version: livecd-tools-15.7-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 23:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oliver Henshaw 2011-03-16 13:28:48 EDT
Description of problem:

Booting kde-x86_64-20110315.01.iso I see this in /var/log/messages:

localhost kernel: [    5.047788] systemd[1]: /etc/mtab is not a symlink or not pointing to /proc/self/mounts. This is not supported anymore. Please make sure to replace this file by a symlink to avoid incorrect or misleading mount(8) output.


It seems that livecd-creator does it's own linking/unlinking of /etc/mtab, quite unaware of the new world order - see historical bug #517394.


Version-Release number of selected component (if applicable):

livecd-tools-15.5 (from inspection of git repo)
Comment 1 Brian Lane 2011-03-21 19:06:52 EDT
The related anaconda bug is bug 670381, which symlinks /etc/mtab to /proc/self/mounts

It looks like this is the right thing to do now that systemd is being used.
Comment 2 Oliver Henshaw 2011-05-03 13:40:54 EDT
Seems unchanged in Fedora-15-Nightly-20110502.18-x86_64-Live-kde.iso
Comment 3 James Laska 2011-05-04 07:49:43 EDT
(In reply to comment #1)
> The related anaconda bug is bug 670381, which symlinks /etc/mtab to
> /proc/self/mounts
> 
> It looks like this is the right thing to do now that systemd is being used.

I don't know of any missing functionality or use cases from the release criteria [1] that will be impacted by this change.  It certainly seems like the right thing to do though, and certainly qualifies as a nice-to-have (NTH) in my view since this isn't something that can be shipped in an update, and is required at live image creation time.

I'm +0 blocker, +1 NTH.

If accepted as a Blocker or NTH, as long as a tested fix is a available, this issue can be pulled into Fedora 15 RC1

[1] http://fedoraproject.org/wiki/Fedora_15_Final_Release_Criteria
Comment 4 Brian Lane 2011-05-04 11:39:47 EDT
Tested a patch against the F15 Beta Live Desktop, worked fine.
Comment 5 Tim Flink 2011-05-06 14:05:13 EDT
Discussed in the 2011-05-06 blocker review meeting. Rejected as blocker since it doesn't hit any of the release criteria. Accepted as NTH because it is needed at live image creation time and not possible to fix in an update.
Comment 6 Fedora Update System 2011-05-06 14:15:14 EDT
livecd-tools-15.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/livecd-tools-15.7-1.fc15
Comment 7 Fedora Update System 2011-05-07 11:09:21 EDT
Package livecd-tools-15.7-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-15.7-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/livecd-tools-15.7-1.fc15
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-05-09 23:26:56 EDT
livecd-tools-15.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-06-08 17:34:26 EDT
livecd-tools-13.4.8-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/livecd-tools-13.4.8-1.el6

Note You need to log in before you can comment on or make changes to this bug.