Bug 688286 - whitespace included at the end of the <productname> tag
whitespace included at the end of the <productname> tag
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
: 705241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-16 13:49 EDT by Eva Kopalova
Modified: 2016-06-17 17:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 20:42:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eva Kopalova 2011-03-16 13:49:23 EDT
Description of problem:
the <productname> tag is rendered with a whitespace at the end of the inserted string.

Version-Release number of selected component (if applicable):


How reproducible:
render:
	<title>Prerequisites</title>
	<para>
		Make sure the following prerequisites are fulfilled before installing <productname>JBoss Enterprise Web Server</productname>:
	</para>
Comment 1 Jeff Fearn 2011-04-18 23:43:27 EDT
Added check for mixed mode tags in XmlClean, skipped adding newlines when para ancestor detected.

Committed revision 1760.
Comment 2 Jeff Fearn 2011-05-19 04:33:38 EDT
*** Bug 705241 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Fearn 2011-07-07 06:31:58 EDT
Back ported to branches/publican-2x

Committed revision 1811.
Comment 4 Jared MORGAN 2011-07-12 19:07:08 EDT
Well, I've verified that the bug reported no longer presents. I used the same syntactical structure the reporter used, and there is no whitespace issue.

Tested on HTML-single and PDF.

I'm not sure whether stylisticly the text should have any style applied to it, such as bold, or italics. This is likely outside the scope of this issue.

Note You need to log in before you can comment on or make changes to this bug.