Bug 688454 - Subscription Manager GUI gets upset when Date field is being set to blank
Subscription Manager GUI gets upset when Date field is being set to blank
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
All Linux
low Severity low
: rc
: ---
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks: rhsm-rhel62 704408 741843
  Show dependency treegraph
 
Reported: 2011-03-17 01:42 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 704408 741843 (view as bug list)
Environment:
Last Closed: 2011-12-06 12:13:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenichi Takemura 2011-03-17 01:42:30 EDT
Description of problem:

Subscription Manager GUI displays the following error dialogue when Date field is being set to blank.

'Invalid date format. Please re-enter a valid date. Example: 03/17/2011'

This error dialogue comes up on every operations excluding Close and setting 'data' manually into the date field. Even the dialogue shows up periodically without any operations.

Version-Release number of selected component (if applicable):

subscription-manager-0.95.4-1.el6.i686
subscription-manager-gnome-0.95.4-1.el6.i686
subscription-manager-firstboot-0.95.4-1.el6.i686


How reproducible:
1000%

Steps to Reproduce:
1. System -> Administration -> Red Hat Subscription Manager
2. Register the system and go to All Available Subscriptions tab
3. Delete date from the field and then click somewhere such as Calendar icon or 'Update' button.
  
Actual results:
An error dialogue keeps coming up.

Expected results:
You can click Calendar to set new date.

Additional info:
Comment 3 Michael Stead 2011-09-21 08:33:36 EDT
Proposed fix is to on error, reset the date picker's date field to the last valid date that was entered. Since the date is valid again, the user can now click the calendar button to select a valid date.


Patch is ready, if this solution is reasonable.
Comment 4 Michael Stead 2011-09-22 09:55:49 EDT
Fixed in:

master 57a82070e778b8b8eba71bc87fd8be5673134f9c

RHEL6.2 f2b4fb279cd018f844f8ccdd6f26220061d14076
Comment 5 J.C. Molet 2011-09-26 11:44:45 EDT
VERIFIED against:

python-rhsm-0.96.12-1.git.0.4862863.el6.noarch
subscription-manager-firstboot-0.96.11-1.git.7.15fc9d2.el6.x86_64
subscription-manager-0.96.11-1.git.7.15fc9d2.el6.x86_64
subscription-manager-gnome-0.96.11-1.git.7.15fc9d2.el6.x86_64

Works exactly as described in  comment 3.  Additional tests were performed to ensure that the default date was in the correct locale format.
Comment 6 errata-xmlrpc 2011-12-06 12:13:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.