Bug 68857 - rpm provides files which name is its error message
rpm provides files which name is its error message
Status: CLOSED DUPLICATE of bug 8527
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-15 05:25 EDT by Nakai
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-15 05:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nakai 2002-07-15 05:25:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020528

Description of problem:
rpm commands provides rpm's error message files in
/usr/src/redhat/SPECS. Such like:

tar: This does not look like a tar archive
tar: *.spec: Not found in archive

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -ta /dev/null
2. It provides a file 'tar: *.spec: Not found in archive' in /usr/src/redhat/SPECS/

1. rpm -ta emacs.spec (some ascii file)
2. It provides a file 'tar: This does not look like a tar archive' in
/usr/src/redhat/SPECS/


Actual Results:  Error messages come to be empty files in /usr/src/redhat/SPECS/

Expected Results:  Error message should be go to stderr, not in files.

Additional info:

I wondered why and who makes this crappy files for
a long time, since I started to touch Red Hat Linux.
So many people should wonder too.
Comment 1 Jeff Johnson 2002-07-15 11:51:50 EDT

*** This bug has been marked as a duplicate of 8527 ***

Note You need to log in before you can comment on or make changes to this bug.