Bug 688648 - seq24 package is outdated
Summary: seq24 package is outdated
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: seq24   
(Show other bugs)
Version: 16
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anthony Green
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 814610 (view as bug list)
Depends On:
Blocks: FedoraAudio
TreeView+ depends on / blocked
 
Reported: 2011-03-17 16:03 UTC by Dirk Meijer
Modified: 2012-07-10 16:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 16:27:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dirk Meijer 2011-03-17 16:03:35 UTC
The package seq24 is outdated in the Fedora repositories.
The version in the repositories is 0.8.7, while upstream is at version 0.9.2

New source code is available at https://launchpad.net/seq24
http://www.filter24.org/seq24/ does not seem to be active anymore.

The update contains new features and stability improvements.

Comment 1 Brendan Jones 2011-05-16 02:49:43 UTC
Anthony, I've packaged this for my own use - would you like me to do the update?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Brendan Jones 2011-12-06 18:06:55 UTC
Here is an updated SRPM (with  patch from trunk to fix lash support bug).

http://bsjones.fedorapeople.org/seq24-0.9.2-1.fc16.src.rpm

--- seq24-0.8.7-18.spec	2011-12-06 17:34:41.137373843 +0100
+++ seq24.spec	2011-12-06 19:05:24.414570657 +0100
@@ -1,24 +1,19 @@
 Summary:      Real-time midi sequencer
 Name:         seq24
-Version:      0.8.7
-Release:      18%{?dist}
+Version:      0.9.2
+Release:      1%{?dist}
 License:      GPLv2+
 Group:        Applications/Multimedia
-URL:          http://www.filter24.org/seq24/
-Source:       http://filter24.org/seq24/seq24-%{version}.tar.gz
-Source1:      seq24.png
-Source2:      seq24.desktop
-Patch0:       seq24-stack-smash.patch
-Patch1:	      seq24-gcc43.patch
-Patch2:       seq24-0.8.7-sigc22-fix.patch
-Patch3:	      seq24-buffer-overflow.patch
-BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+URL:          http://launchpad.net/%{name}
+Source:       http://launchpad.net/%{name}/trunk/%{version}/+download/%{name}-%{version}.tar.gz
+Source1:      %{name}.png
+Source2:      %{name}.desktop
+# patch from upstream to fix lash
+Patch0:       %{name}-%{version}-lash-fix.patch
 
 BuildRequires: lash-devel gtkmm24-devel
-
-Requires: hicolor-icon-theme
-
 BuildRequires: desktop-file-utils
+Requires: hicolor-icon-theme
 
 %description 
 Seq24 is a real-time midi sequencer. It provides a very simple
@@ -26,34 +21,24 @@ interface for editing and playing midi '
 
 %prep
 %setup -q
-%patch0 -p0 -b .stack-smash~
-%patch1 -p1 -b .gcc43~
-%patch2 -p1 -b .sigc22
-%patch3 -p0 -b .buffer-overflow
+%patch0 -p1 
 
 %build
-echo %configure
 %configure
 make %{?_smp_mflags}
 
 %install
-rm -rf $RPM_BUILD_ROOT
 make DESTDIR=$RPM_BUILD_ROOT install
 
-# Rename the "dump" command to something more specific.
-mv $RPM_BUILD_ROOT%{_bindir}/dump $RPM_BUILD_ROOT%{_bindir}/seq24-dump
-
 mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps
-install -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/seq24.png
+install -m 644 %{SOURCE1} \
+  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/%{name}.png
 
 mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
 desktop-file-install --vendor fedora \
   --dir $RPM_BUILD_ROOT%{_datadir}/applications    \
   %{SOURCE2}
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %post
 touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
 
@@ -68,13 +53,17 @@ gtk-update-icon-cache %{_datadir}/icons/
 
 
 %files
-%defattr(-,root,root,-)
 %doc AUTHORS ChangeLog COPYING README RTC SEQ24 TODO seq24usr.example
 %{_bindir}/*
 %{_datadir}/applications/*%{name}.desktop
-%{_datadir}/icons/hicolor/64x64/apps/seq24.png
+%{_datadir}/icons/hicolor/64x64/apps/%{name}.png
+%{_datadir}/man/man1/%{name}.1.gz
 
 %changelog
+* Mon Nov 14 2011 Brendan Jones <brendan.jones.it@gmail.com> - 0.9.2-1
+- New upstream version 0.9.2
+- Removed obsolete tags and and sections
+
 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.7-18
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

Comment 3 Brendan Jones 2012-04-21 10:08:48 UTC
*** Bug 814610 has been marked as a duplicate of this bug. ***

Comment 4 Brendan Jones 2012-04-21 10:17:23 UTC
Anthony, can we get an update here? I'm happy to do it (ACLs pending).

Comment 5 Fedora Update System 2012-06-08 20:41:27 UTC
seq24-0.9.3-0.1.r131.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/seq24-0.9.3-0.1.r131.fc17

Comment 6 Fedora Update System 2012-06-08 20:41:54 UTC
seq24-0.9.3-0.1.r131.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/seq24-0.9.3-0.1.r131.fc16

Comment 7 Fedora Update System 2012-06-10 01:25:56 UTC
Package seq24-0.9.3-0.1.r131.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing seq24-0.9.3-0.1.r131.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9162/seq24-0.9.3-0.1.r131.fc16
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-07-10 16:27:01 UTC
seq24-0.9.3-0.1.r131.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2012-07-10 16:32:10 UTC
seq24-0.9.3-0.1.r131.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.