Bug 688661 - systemctl isolate multi-user.target doesn't run getty on tty1 when coming from graphical.target
Summary: systemctl isolate multi-user.target doesn't run getty on tty1 when coming fro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-17 16:32 UTC by Reartes Guillermo
Modified: 2011-05-01 03:23 UTC (History)
6 users (show)

Fixed In Version: systemd-25-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-01 03:23:21 UTC
Type: ---


Attachments (Terms of Use)

Description Reartes Guillermo 2011-03-17 16:32:29 UTC
Description of problem:


Version-Release number of selected component (if applicable):

kernel 2.6.38-1.fc15.x86_64
systemd.x86_64             20-1.fc15
systemd-units.x86_64       20-1.fc15

How reproducible:


Steps to Reproduce:
1. open konsole
2. su -
3. init 1
  
Actual results:
system reaches runlevel 3, but tty1 is not usable. must manually switch to tty2.

Expected results:
the current tty (tty1) must be usable after reaching runlevel1

Additional info:

Comment 1 Reartes Guillermo 2011-03-24 23:06:20 UTC
I installed another machine, updated it and reproduced it.
SELinux is PERMISSIVE.

When executing an 'init 1' the following appears in the messages:

Mar 24 18:32:09 f15a kdm: :0[1085]: Cannot close ConsoleKit session: Unable to close session: Unable to find session for cookie

i wonder if it is related...

-----

Additional info:

* tty1 is unusable, i must press ALT+F2 to use the next avaiable one.

* from tty2, a 'ps aux|grep tty' shows that no agetty is running for
tty1 and tty2(ok, because i am logged in there).

-----

Results after hitting this bug:

If i perform a 'systemctl default' or 'init 5' it executes it correctly.
But then i perform an 'init 1' i sent my computer to a black-hole
Issuing an 'init 1' from cold-boot works fine.

* Bug 688658 - F15 issuing 'init 1' from konsole [via su -] causes black screen/no signal (with serial port console there is no black screen), must use reset button

Comment 2 Michal Schmidt 2011-04-04 21:04:56 UTC
Does tty1 become usable again if you do "systemctl start getty@tty1.service"?

It is probably the same problem that Lennart put in his TODO some time ago:

* isolate multi-user.target doesn't start a getty@tty1 if we run it from 
graphical.target

Comment 3 Reartes Guillermo 2011-04-04 23:46:42 UTC
> Does tty1 become usable again if you do "systemctl start getty@tty1.service"?

yes, if i issue 'init 3' from graphical.target and then
from tty2 issue 'systemctl start getty@tty1.service' tty1 works.

Comment 4 Lennart Poettering 2011-04-08 02:49:19 UTC
Fixed in git.

Comment 5 Fedora Update System 2011-04-21 02:00:12 UTC
systemd-25-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-25-1.fc15

Comment 6 Fedora Update System 2011-04-21 03:01:38 UTC
Package systemd-25-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-25-1.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/systemd-25-1.fc15
then log in and leave karma (feedback).

Comment 7 Reartes Guillermo 2011-04-24 15:33:46 UTC
Tested with these versions:

systemd.x86_64           25-1.fc15          @updates-testing
systemd-units.x86_64     25-1.fc15          @updates-testing

It correctly starts tty1 now, so, fixed.

Comment 8 Fedora Update System 2011-05-01 03:22:37 UTC
systemd-25-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.