Bug 68960 - for wireless: default gateway missing in route table
for wireless: default gateway missing in route table
Product: Red Hat Raw Hide
Classification: Retired
Component: dhcp (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Brock Organ
: 70082 (view as bug list)
Depends On:
Blocks: 67217 79578
  Show dependency treegraph
Reported: 2002-07-16 11:30 EDT by Fortepianissimo
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-07-28 18:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/sysconfig/network (66 bytes, text/plain)
2002-07-16 23:53 EDT, Fortepianissimo
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0 (125 bytes, text/plain)
2002-07-16 23:54 EDT, Fortepianissimo
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0 (271 bytes, text/plain)
2002-07-16 23:54 EDT, Fortepianissimo
no flags Details
/var/lib/dhcp/dhclient-eth1.leases (507 bytes, text/plain)
2002-09-03 15:36 EDT, Fortepianissimo
no flags Details

  None (edit)
Description Fortepianissimo 2002-07-16 11:30:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020715

Description of problem:
the scripts didn't set the default gateway in route table for wireless card.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.pop in an Orinoco Silver card
2.try to ping anywhere with IP address
3.network unreachable

Actual Results:  route table missing the default gateway

Expected Results:  should have an entry for default gateway

Additional info:


If I downgraded to initscripts-6.78-2 (and kept everything else intact)
everything worked fine.
Comment 1 Bill Nottingham 2002-07-16 22:36:54 EDT
Please post your /etc/sysconfig/network and
/etc/sysconfig/network-scripts/ifcfg-<device>, thanks!
Comment 2 Fortepianissimo 2002-07-16 23:53:44 EDT
Created attachment 65604 [details]
Comment 3 Fortepianissimo 2002-07-16 23:54:29 EDT
Created attachment 65605 [details]
Comment 4 Fortepianissimo 2002-07-16 23:54:54 EDT
Created attachment 65606 [details]
Comment 5 Bill Nottingham 2002-08-13 16:59:48 EDT
What default gateway do you want it to set? (There doesn't appear to be one
listed for the wireless network...)
Comment 6 Bill Nottingham 2002-08-13 21:43:04 EDT
*** Bug 70082 has been marked as a duplicate of this bug. ***
Comment 7 Fortepianissimo 2002-08-15 06:15:56 EDT
In initscripts-6.67-1 the default gateway was correctly set via dhcp. So it's 
probably not something fixed?
Comment 8 Fortepianissimo 2002-08-22 16:24:25 EDT
initscripts-6.91-1 still has the same problem (the last version that worked for
me is initscripts-6.67-1).
Comment 9 Bill Nottingham 2002-08-29 18:17:39 EDT
Hm, I can't reproduce this here with what is (essentially) your config. It's not
using wireless, but that *shouldn't* make a difference. What does your
/var/lib/dhcp/dhclient-eth1.leases look like?
Comment 10 Fortepianissimo 2002-09-03 15:36:53 EDT
Created attachment 74744 [details]
Comment 11 Bill Nottingham 2002-09-03 15:49:18 EDT
And, just to clarify, what version of dhclient do you have running?
Comment 12 Fortepianissimo 2002-09-03 16:11:08 EDT
I have dhclient-3.0pl1-9 installed, but not the other dhcp packages. Well 
actually before I installed initscripts-6.92 I was running initscripts-6.67 
with an older version of dhcp client, and I didn't have /var/lib/dhcp/dhclient-
eth1.leases. It's after seeing your message that prompted me to check what dhcp 
client I was running. So I removed the old dhcp client, installed the current 
initscripts and dhclient - but still no luck.
Comment 13 Bill Nottingham 2002-09-03 16:34:38 EDT
Moving to dhclient; the default route gets set there, unless I'm really missing
Comment 14 Fortepianissimo 2002-10-06 18:41:32 EDT
RH 8.0 has the same behavior (i.e., the default gateway is not set after
inserting the wireless card). However I managed to fix this, by adding a file
/sbin/ifup-pre-local containing this:


case $1 in

        route del default

and add back my default gateway in /sbin/ifdown-local:


case $1 in

        route add default gw
Comment 15 Daniel Walsh 2003-01-24 15:44:42 EST
I believe the routers are only going to be set if the server is handing down a
default route.  So is your dhcpd set up to hand down routes?

Comment 16 Bill Nottingham 2003-07-28 18:07:31 EDT
Closing, lack of response.

Note You need to log in before you can comment on or make changes to this bug.