Bug 68960 - for wireless: default gateway missing in route table
Summary: for wireless: default gateway missing in route table
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: dhcp (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 70082 (view as bug list)
Depends On:
Blocks: 67217 79578
TreeView+ depends on / blocked
 
Reported: 2002-07-16 15:30 UTC by Fortepianissimo
Modified: 2007-04-18 16:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 22:07:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/network (66 bytes, text/plain)
2002-07-17 03:53 UTC, Fortepianissimo
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0 (125 bytes, text/plain)
2002-07-17 03:54 UTC, Fortepianissimo
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0 (271 bytes, text/plain)
2002-07-17 03:54 UTC, Fortepianissimo
no flags Details
/var/lib/dhcp/dhclient-eth1.leases (507 bytes, text/plain)
2002-09-03 19:36 UTC, Fortepianissimo
no flags Details

Description Fortepianissimo 2002-07-16 15:30:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020715

Description of problem:
the scripts didn't set the default gateway in route table for wireless card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.pop in an Orinoco Silver card
2.try to ping anywhere with IP address
3.network unreachable
	

Actual Results:  route table missing the default gateway

Expected Results:  should have an entry for default gateway

Additional info:

kernel-pcmcia-cs-3.1.31-6
hotplug-2002_04_01-9
kernel-2.4.18-5.69

If I downgraded to initscripts-6.78-2 (and kept everything else intact)
everything worked fine.

Comment 1 Bill Nottingham 2002-07-17 02:36:54 UTC
Please post your /etc/sysconfig/network and
/etc/sysconfig/network-scripts/ifcfg-<device>, thanks!

Comment 2 Fortepianissimo 2002-07-17 03:53:44 UTC
Created attachment 65604 [details]
/etc/sysconfig/network

Comment 3 Fortepianissimo 2002-07-17 03:54:29 UTC
Created attachment 65605 [details]
/etc/sysconfig/network-scripts/ifcfg-eth0

Comment 4 Fortepianissimo 2002-07-17 03:54:54 UTC
Created attachment 65606 [details]
/etc/sysconfig/network-scripts/ifcfg-eth0

Comment 5 Bill Nottingham 2002-08-13 20:59:48 UTC
What default gateway do you want it to set? (There doesn't appear to be one
listed for the wireless network...)

Comment 6 Bill Nottingham 2002-08-14 01:43:04 UTC
*** Bug 70082 has been marked as a duplicate of this bug. ***

Comment 7 Fortepianissimo 2002-08-15 10:15:56 UTC
In initscripts-6.67-1 the default gateway was correctly set via dhcp. So it's 
probably not something fixed?

Comment 8 Fortepianissimo 2002-08-22 20:24:25 UTC
initscripts-6.91-1 still has the same problem (the last version that worked for
me is initscripts-6.67-1).

Comment 9 Bill Nottingham 2002-08-29 22:17:39 UTC
Hm, I can't reproduce this here with what is (essentially) your config. It's not
using wireless, but that *shouldn't* make a difference. What does your
/var/lib/dhcp/dhclient-eth1.leases look like?

Comment 10 Fortepianissimo 2002-09-03 19:36:53 UTC
Created attachment 74744 [details]
/var/lib/dhcp/dhclient-eth1.leases

Comment 11 Bill Nottingham 2002-09-03 19:49:18 UTC
And, just to clarify, what version of dhclient do you have running?

Comment 12 Fortepianissimo 2002-09-03 20:11:08 UTC
I have dhclient-3.0pl1-9 installed, but not the other dhcp packages. Well 
actually before I installed initscripts-6.92 I was running initscripts-6.67 
with an older version of dhcp client, and I didn't have /var/lib/dhcp/dhclient-
eth1.leases. It's after seeing your message that prompted me to check what dhcp 
client I was running. So I removed the old dhcp client, installed the current 
initscripts and dhclient - but still no luck.

Comment 13 Bill Nottingham 2002-09-03 20:34:38 UTC
Moving to dhclient; the default route gets set there, unless I'm really missing
something.

Comment 14 Fortepianissimo 2002-10-06 22:41:32 UTC
RH 8.0 has the same behavior (i.e., the default gateway is not set after
inserting the wireless card). However I managed to fix this, by adding a file
/sbin/ifup-pre-local containing this:

#!/bin/sh

case $1 in
    eth0)
    ;;

    eth1)
        route del default
    ;;


and add back my default gateway in /sbin/ifdown-local:

#!/bin/sh

case $1 in
    eth0)
    ;;

    eth1)
        route add default gw 192.168.1.1
    ;;
esac


Comment 15 Daniel Walsh 2003-01-24 20:44:42 UTC
I believe the routers are only going to be set if the server is handing down a
default route.  So is your dhcpd set up to hand down routes?

Dan

Comment 16 Bill Nottingham 2003-07-28 22:07:31 UTC
Closing, lack of response.


Note You need to log in before you can comment on or make changes to this bug.