Bug 689823 - [AMTU] "Failed to get list of network interfaces to test."
Summary: [AMTU] "Failed to get list of network interfaces to test."
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: amtu
Version: 6.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Paul Moore
QA Contact: Jaroslav Aster
URL:
Whiteboard:
: 682339 (view as bug list)
Depends On:
Blocks: 682269 1070830
TreeView+ depends on / blocked
 
Reported: 2011-03-22 14:46 UTC by Jeff Burke
Modified: 2014-06-09 06:56 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, Abstract Machine Test Utility (AMTU) did not handle the name of the interface correctly under certain circumstances. As a consequence, AMTU failed to obtain a list of network interfaces to test. With this update, the interface hardware type and carriers are obtained from the /sys/class/net/ directory. Now, only an Ethernet and a token ring can be used, and a carrier must be present. As a result, AMTU handles the new network interface names as expected.
Clone Of:
Environment:
Last Closed: 2014-06-09 06:56:29 UTC


Attachments (Terms of Use)
proposed patch - check ifc type and carrier in /sys (4.09 KB, patch)
2011-08-25 11:38 UTC, Jan Stancek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0639 normal SHIPPED_LIVE amtu bug fix update 2014-06-09 10:56:11 UTC

Description Jeff Burke 2011-03-22 14:46:21 UTC
Description of problem:
 AMTU fails the network portion of the test

Version-Release number of selected component (if applicable):
2.6.32-125.el6

How reproducible:
Always on systems that are effected by the biosdevname changes in 6.1

Steps to Reproduce:
1. Install Dell 11g system with RHEL6.1 beta
2. Install the AMTU test package.
3. Run the network portion of the AMTU test.
  
Actual results:
Failed to get list of network interfaces to test

Expected results:
AMTU should be able to handle the new network interface names.

Additional info:

Comment 3 RHEL Product and Program Management 2011-03-22 15:08:59 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Bill Nottingham 2011-04-05 17:36:11 UTC
Dup of 682339?

Comment 11 Steve Grubb 2011-08-13 17:10:18 UTC
Yes, they can be moved. The work around is to change our test scripts to use:
amtu -dmsip   which does all tests but the network tests.

Comment 16 Jan Stancek 2011-08-25 11:38:00 UTC
Created attachment 519817 [details]
proposed patch - check ifc type and carrier in /sys

[PATCH] networkio: check ifc type and carrier in /sys

With biosdevname changes it's no longer valid to check
interface type just by name of interface.

This patch will get interface hardware type and carrier from
/sys/class/net. As in previous implementation, only ethernet
and token ring can be used, and carrier must be present.

Difference is, that now all devices, that match this criteria,
will get tested, e.g. bridge or tap devices too.

Patch aims to resolve these bugs:
Bug 689823 - [AMTU] "Failed to get list of network interfaces to test."
https://bugzilla.redhat.com/show_bug.cgi?id=689823

Bug 723049 - [RHEL6.0] AMTU Running network tests on interfaces that
have no link
https://bugzilla.redhat.com/show_bug.cgi?id=723049

Before:
[root@dell-pem710 amtu-1.0.8]# ./src/amtu -dn
Executing Network I/O Tests...
Failed to get list of network interfaces to test.

After:
[root@dell-pem710 amtu-1.0.8]# ./src/amtu -dn
Executing Network I/O Tests...
if:    lo, type:  772, carrier:   1
if:   em1, type:    1, carrier:   1
if:   em2, type:    1, carrier:   1
if:   em3, type:    1, carrier:  -1
if:   em4, type:    1, carrier:  -1
if:    lo, type:  772, carrier:   1
if:   em1, type:    1, carrier:   1
if:    lo, type:  772, carrier:   1
if:   em1, type:    1, carrier:   1
if:   em1, type:    1, carrier:   1
if:   em2, type:    1, carrier:   1
if:   em2, type:    1, carrier:   1

Interface list to test:
   em1
   em2

Comment 18 Steve Grubb 2012-05-14 15:51:53 UTC
*** Bug 682339 has been marked as a duplicate of this bug. ***

Comment 21 David Spurek 2012-09-06 11:15:34 UTC
Hi Jan,
I try to reproduce this bug as your comment show.

my steps:
install amtu package

[root@dell-pem905-01 ~]# rpm -q amtu
amtu-1.0.8-8.el6.x86_64

cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.1 (Santiago)

uname -a
Linux dell-pem905-01.rhts.eng.bos.redhat.com 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux


amtu -dn
Executing Network I/O Tests...

Interface list to test:
   eth0

message string: U@ O6VU9Ra#7mF3T.>*dO-EpyE?eev;:/LNooN&\Y1oHk>u0.n/snYjd$"pa`07<Dmb]*2Ja=P|4+!HM)_qY.'>x+AJs^XUk%2gY]!*K$ 9BGUCMnFa8:?[|4cjl/z>Ka $mQOJ[iWNv;[`'u->#QV)(`:1f<t`V^7$Tr5*F=26d8^DOv52)|4-\&-@8;Gxy/jR.!%$VAW>`rc;tXs/_:'j3-bVoEwjMUAM!T.7i+v\ZU@I.D+E.t`5-V8;nc1K=a>G+lV1&q;90#eF;<GXA/bDzK\]I]zDN5}neK\L#$H"7w|r#GNZUIx2C<y:o^P)-M0Pqxs)pw%bl0Fe>7({8!5'()2uZfRvBm4$!T$gY&1!ISVqS[|Vt)kt8}Yd!A>*gO[.^9"~G0TX%}_)iTayQ;]r|cjwk&I'/%J_z"w-`VY'J7FR5)=,@R]Lz_{)[L_Nq$KKfd,TUEiQF%1OtKT\iaM}Xc<oUdMR2pD8v~A"R3j0p,"S_NfOX&VJH(gT[QlT]

Beginning test for eth0
Received: U@ O6VU9Ra#7mF3T.>*dO-EpyE?eev;:/LNooN&\Y1oHk>u0.n/snYjd$"pa`07<Dmb]*2Ja=P|4+!HM)_qY.'>x+AJs^XUk%2gY]!*K$ 9BGUCMnFa8:?[|4cjl/z>Ka $mQOJ[iWNv;[`'u->#QV)(`:1f<t`V^7$Tr5*F=26d8^DOv52)|4-\&-@8;Gxy/jR.!%$VAW>`rc;tXs/_:'j3-bVoEwjMUAM!T.7i+v\ZU@I.D+E.t`5-V8;nc1K=a>G+lV1&q;90#eF;<GXA/bDzK\]I]zDN5}neK\L#$H"7w|r#GNZUIx2C<y:o^P)-M0Pqxs)pw%bl0Fe>7({8!5'()2uZfRvBm4$!T$gY&1!ISVqS[|Vt)kt8}Yd!A>*gO[.^9"~G0TX%}_)iTayQ;]r|cjwk&I'/%J_z"w-`VY'J7FR5)=,@R]Lz_{)[L_Nq$KKfd,TUEiQF%1OtKT\iaM}Xc<oUdMR2pD8v~A"R3j0p,"S_NfOX&VJH(gT[QlT]
Interface eth0 passed test.
Network I/O Controller Test SUCCESS!


Can you give me the advice how reproduce this bug? Is it depends on some hardware (dell?) or some machine configuration?

Comment 22 Jan Stancek 2012-09-06 11:27:28 UTC
(In reply to comment #21)
> Can you give me the advice how reproduce this bug? Is it depends on some
> hardware (dell?) or some machine configuration?

It depends on name of interface, so it's more likely to occur on machines where biosdevname is in effect (like Dell ones). Make sure you are not disabling biosdevname (for example biosdevname=0). Any machine where interface name doesn't match 'eth*' should be fine.

Other option that comes to mind is to rename interface by hand:
ifconfig eth0 down
ip link set eth0 name em1
ifconfig em1 up
dhclient em1
amtu -dn

Comment 27 Jeff Burke 2013-11-27 16:34:50 UTC
Sue Forsberg, 
 Jan has created a patch for this. It has been fasttacked for several releases. But seems Steve does not have time for ATMU. 

 Any chance you can get this BZ reassigned. 

Regards,
Jeff

Comment 29 Paul Moore 2013-12-06 22:28:40 UTC
This appears to have been fixed in Rawhide, see BZ #682337.

Comment 31 Paul Moore 2013-12-06 22:35:29 UTC
I've verified that the attached patch works for me on a current Rawhide system.  

Unfortunately, my RHEL6.x systems don't exhibit the device naming issues as described in the original report, but using the patched RHEL6.x source RPM (see the Brew build link above) on a Rawhide system I've been able to verify the fix.

I see no reason why this patch shouldn't be merged for RHEL6.x.

Comment 40 errata-xmlrpc 2014-06-09 06:56:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0639.html


Note You need to log in before you can comment on or make changes to this bug.