Bug 723049 - [RHEL6.0] AMTU Running network tests on interfaces that have no link
Summary: [RHEL6.0] AMTU Running network tests on interfaces that have no link
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: amtu
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Paul Moore
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-18 20:32 UTC by Jeff Burke
Modified: 2014-06-09 06:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, Abstract Machine Test Utility (AMTU) ran network tests on interfaces configured with a static IP that did not have an existing connection, causing those tests to fail. With this update, AMTU no longer runs tests on interfaces that are not up.
Clone Of:
Environment:
Last Closed: 2014-06-09 06:56:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0639 normal SHIPPED_LIVE amtu bug fix update 2014-06-09 10:56:11 UTC

Description Jeff Burke 2011-07-18 20:32:54 UTC
Description of problem:
 While running the AMTU test on a system that has static interfaces the test is failing.

Version-Release number of selected component (if applicable):
amtu-1.0.8-8.el6.i686

How reproducible:
always

Steps to Reproduce:
1. Install a RHEL6 system
2. Configure an interface with a static IP but leave it unplugged.
3. Run amtu -dn, It will fail.
  
Actual results:

 According the the AMTU help. 

  * I/O Controller - Network
      Verifies  random data transmitted is also the data received for each configured network device.  Checks only Ethernet and token ring devices that are configured and up.  Does not check async devices.

AMTU should be checking if the interface is up before running the test.

---------------------------
# amtu -dn
Executing Network I/O Tests...

Interface list to test:
   eth6
   eth0
   eth2
   eth3
   eth4
   eth5

message string: R6KNQ:QR>Vu3zissN],v{MGMUM3&r|0#Ys>v9DQHc"0VCOH@dXprpz+S(,Ff"Pf!%.HK5fOh>?[.Hc)^|;Cl]D41r8y>mMr}Z;[5j#(cRu@e1wR*5?A1>zyAdZw'eY&>*XN!*xVi:Xxv'rohVCM*ETQ+-mQk{CXmPsWLrBu2L>Dhm:5'1I7Zd^g ]R)_Byi03JZ$P%DQoV_T4_;Tx'A7q0Z4cx~>OJBi_:O\#x^dpw8Ct<sNpWGoc>_%'>+az0r|bd>JX{>'knZ*Qw?G" U*A=nESY+TMR?b@2r]+2U-79LT(f{?)&vySY9meK{TX$UQAlA2tZ-3TGzMS8R&3&8&\|-Wh7d)jXkS8mT?t@7RL^.aZ[8Bl}upwTy8AMw5ZP@"gQHx,:?&<QQi+T`/0JIS1g$y_Pz@L,WAen*lxU@y6of9L9j3]d.^->wm#D(d)dVEV:iME,I#7F{6*%L8:[b6Vl7UBq>LhN82Q[i_!dKbD= TV*N~>JU5&]~I}LP:l$ZC���	��	H��	x��	������	

Beginning test for eth6
recvfrom failed to receive message on eth6

Beginning test for eth0
Received: R6KNQ:QR>Vu3zissN],v{MGMUM3&r|0#Ys>v9DQHc"0VCOH@dXprpz+S(,Ff"Pf!%.HK5fOh>?[.Hc)^|;Cl]D41r8y>mMr}Z;[5j#(cRu@e1wR*5?A1>zyAdZw'eY&>*XN!*xVi:Xxv'rohVCM*ETQ+-mQk{CXmPsWLrBu2L>Dhm:5'1I7Zd^g ]R)_Byi03JZ$P%DQoV_T4_;Tx'A7q0Z4cx~>OJBi_:O\#x^dpw8Ct<sNpWGoc>_%'>+az0r|bd>JX{>'knZ*Qw?G" U*A=nESY+TMR?b@2r]+2U-79LT(f{?)&vySY9meK{TX$UQAlA2tZ-3TGzMS8R&3&8&\|-Wh7d)jXkS8mT?t@7RL^.aZ[8Bl}upwTy8AMw5ZP@"gQHx,:?&<QQi+T`/0JIS1g$y_Pz@L,WAen*lxU@y6of9L9j3]d.^->wm#D(d)dVEV:iME,I#7F{6*%L8:[b6Vl7UBq>LhN82Q[i_!dKbD= TV*N~>JU5&]~I}LP:l$ZC
Interface eth0 passed test.

Beginning test for eth2
Received: R6KNQ:QR>Vu3zissN],v{MGMUM3&r|0#Ys>v9DQHc"0VCOH@dXprpz+S(,Ff"Pf!%.HK5fOh>?[.Hc)^|;Cl]D41r8y>mMr}Z;[5j#(cRu@e1wR*5?A1>zyAdZw'eY&>*XN!*xVi:Xxv'rohVCM*ETQ+-mQk{CXmPsWLrBu2L>Dhm:5'1I7Zd^g ]R)_Byi03JZ$P%DQoV_T4_;Tx'A7q0Z4cx~>OJBi_:O\#x^dpw8Ct<sNpWGoc>_%'>+az0r|bd>JX{>'knZ*Qw?G" U*A=nESY+TMR?b@2r]+2U-79LT(f{?)&vySY9meK{TX$UQAlA2tZ-3TGzMS8R&3&8&\|-Wh7d)jXkS8mT?t@7RL^.aZ[8Bl}upwTy8AMw5ZP@"gQHx,:?&<QQi+T`/0JIS1g$y_Pz@L,WAen*lxU@y6of9L9j3]d.^->wm#D(d)dVEV:iME,I#7F{6*%L8:[b6Vl7UBq>LhN82Q[i_!dKbD= TV*N~>JU5&]~I}LP:l$ZC
Interface eth2 passed test.

Beginning test for eth3
Received: R6KNQ:QR>Vu3zissN],v{MGMUM3&r|0#Ys>v9DQHc"0VCOH@dXprpz+S(,Ff"Pf!%.HK5fOh>?[.Hc)^|;Cl]D41r8y>mMr}Z;[5j#(cRu@e1wR*5?A1>zyAdZw'eY&>*XN!*xVi:Xxv'rohVCM*ETQ+-mQk{CXmPsWLrBu2L>Dhm:5'1I7Zd^g ]R)_Byi03JZ$P%DQoV_T4_;Tx'A7q0Z4cx~>OJBi_:O\#x^dpw8Ct<sNpWGoc>_%'>+az0r|bd>JX{>'knZ*Qw?G" U*A=nESY+TMR?b@2r]+2U-79LT(f{?)&vySY9meK{TX$UQAlA2tZ-3TGzMS8R&3&8&\|-Wh7d)jXkS8mT?t@7RL^.aZ[8Bl}upwTy8AMw5ZP@"gQHx,:?&<QQi+T`/0JIS1g$y_Pz@L,WAen*lxU@y6of9L9j3]d.^->wm#D(d)dVEV:iME,I#7F{6*%L8:[b6Vl7UBq>LhN82Q[i_!dKbD= TV*N~>JU5&]~I}LP:l$ZC
Interface eth3 passed test.

Beginning test for eth4
Received: R6KNQ:QR>Vu3zissN],v{MGMUM3&r|0#Ys>v9DQHc"0VCOH@dXprpz+S(,Ff"Pf!%.HK5fOh>?[.Hc)^|;Cl]D41r8y>mMr}Z;[5j#(cRu@e1wR*5?A1>zyAdZw'eY&>*XN!*xVi:Xxv'rohVCM*ETQ+-mQk{CXmPsWLrBu2L>Dhm:5'1I7Zd^g ]R)_Byi03JZ$P%DQoV_T4_;Tx'A7q0Z4cx~>OJBi_:O\#x^dpw8Ct<sNpWGoc>_%'>+az0r|bd>JX{>'knZ*Qw?G" U*A=nESY+TMR?b@2r]+2U-79LT(f{?)&vySY9meK{TX$UQAlA2tZ-3TGzMS8R&3&8&\|-Wh7d)jXkS8mT?t@7RL^.aZ[8Bl}upwTy8AMw5ZP@"gQHx,:?&<QQi+T`/0JIS1g$y_Pz@L,WAen*lxU@y6of9L9j3]d.^->wm#D(d)dVEV:iME,I#7F{6*%L8:[b6Vl7UBq>LhN82Q[i_!dKbD= TV*N~>JU5&]~I}LP:l$ZC
Interface eth4 passed test.

Beginning test for eth5
Received: R6KNQ:QR>Vu3zissN],v{MGMUM3&r|0#Ys>v9DQHc"0VCOH@dXprpz+S(,Ff"Pf!%.HK5fOh>?[.Hc)^|;Cl]D41r8y>mMr}Z;[5j#(cRu@e1wR*5?A1>zyAdZw'eY&>*XN!*xVi:Xxv'rohVCM*ETQ+-mQk{CXmPsWLrBu2L>Dhm:5'1I7Zd^g ]R)_Byi03JZ$P%DQoV_T4_;Tx'A7q0Z4cx~>OJBi_:O\#x^dpw8Ct<sNpWGoc>_%'>+az0r|bd>JX{>'knZ*Qw?G" U*A=nESY+TMR?b@2r]+2U-79LT(f{?)&vySY9meK{TX$UQAlA2tZ-3TGzMS8R&3&8&\|-Wh7d)jXkS8mT?t@7RL^.aZ[8Bl}upwTy8AMw5ZP@"gQHx,:?&<QQi+T`/0JIS1g$y_Pz@L,WAen*lxU@y6of9L9j3]d.^->wm#D(d)dVEV:iME,I#7F{6*%L8:[b6Vl7UBq>LhN82Q[i_!dKbD= TV*N~>JU5&]~I}LP:l$ZC
Interface eth5 passed test.
Network I/O Controller Test Failed.
-----------------------------------
# ethtool eth6
Settings for eth6:
	Supported ports: [ FIBRE ]
	Supported link modes:   10000baseT/Full 
	Supports auto-negotiation: No
	Advertised link modes:  10000baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: No
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: FIBRE
	PHYAD: 0
	Transceiver: external
	Auto-negotiation: off
	Supports Wake-on: d
	Wake-on: d
	Current message level: 0x00000007 (7)
	Link detected: no

Expected results:
Test should not run on interfaces that are not up.

Additional info:

Comment 2 RHEL Product and Program Management 2011-07-18 20:58:04 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 RHEL Product and Program Management 2012-07-10 06:12:10 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 9 RHEL Product and Program Management 2012-07-10 23:04:15 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 11 Jeff Burke 2013-02-06 13:50:58 UTC
Steve,
 We stopped using the network portion of AMTU a while back since it would fail. 

***** Starting the runtest.sh script *****
***** Current Running Kernel Package = kernel-2.6.32-358.el6.i686 *****
***** Current Running AMTU Package = amtu-1.0.8-8.el6.i686 *****
***** Current Running Distro = Red Hat Enterprise Linux Server release 6.4 Beta (Santiago) *****
skip network part: Bug 689823, 723049
***** End of runtest.sh *****

 Any chance you will fix this for 6.5? 

Regards,
Jeff

Comment 17 Paul Moore 2013-12-06 22:43:42 UTC
Using the patch posted in BZ #689823, it would appear that this problem is fixed, and based on my limited testing it appears to sense the carrier correctly and avoid downed interfaces.

This patch provided in BZ #689823 is also present in recent Rawhide releases of AMTU.

Comment 28 errata-xmlrpc 2014-06-09 06:56:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0639.html


Note You need to log in before you can comment on or make changes to this bug.