This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 689851 - /sbin/fence_bladecenter --missing_as_off reboot action fails on missing blade
/sbin/fence_bladecenter --missing_as_off reboot action fails on missing blade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks: 708052 708053
  Show dependency treegraph
 
Reported: 2011-03-22 12:13 EDT by Shane Bradley
Modified: 2012-02-21 00:24 EST (History)
5 users (show)

See Also:
Fixed In Version: cman-2.0.115-88.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 708052 708053 (view as bug list)
Environment:
Last Closed: 2012-02-21 00:24:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (1.32 KB, patch)
2011-05-26 12:05 EDT, Marek Grac
no flags Details | Diff

  None (edit)
Description Shane Bradley 2011-03-22 12:13:00 EDT
Description of problem:
When a blade is removed from a blade chassis and is fenced with --missing-as-off option and an action of reboot the fence will fail.  This should not occur. The fence should succeed since it is not in the chassis.

For example the command that is used on blade that is removed from chassis:
$ /sbin/fence_bladecenter -a ibmbladectr1 -l admin -p password -n 6 --missing-as-off -o reboot
Connection timed out
$ echo $?
1

The action "off" will work as expected and returns 0.

Version-Release number of selected component (if applicable):
cman-2.0.115-68.el5_6.1

How reproducible:
Everytime

Steps to Reproduce:
1. Remove blade from a chassis
2. Fence the blade with missing_as_off option and reboot action
3. Fence will fail
  
Actual results:
A failed fence will occur.

Expected results:
A successful fence should occur.

Additional info:
Comment 3 Marek Grac 2011-05-26 12:05:29 EDT
Created attachment 501135 [details]
Proposed patch

Fixing problem when prompt was not changed as expected.

Test case:

let's suppose that blade 6 is not here, and blade 5 is 

fence_bladecenter -l USER -p PASS -n 6 -a blade.control.com -o reboot

should not pass correctly

fence_bladecenter -l USER -p PASS -n 6 -a blade.control.com -o reboot -M

should pass correctly with message that waiting for power on timed out (but fencing was successfull)
Comment 8 errata-xmlrpc 2012-02-21 00:24:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0167.html

Note You need to log in before you can comment on or make changes to this bug.