Bug 69020 - strange dependencies in 5.8.0-30
strange dependencies in 5.8.0-30
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: perl (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-16 22:56 EDT by sean
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: RH9+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 07:08:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2002-07-16 22:56:00 EDT
Description of Problem:

I rebuilt perl-5.8.0-30. On install, however, I get really odd dependenies:

error: failed dependencies:
	all:   is needed by perl-5.8.0-30
	BEGIN   is needed by perl-5.8.0-30
	/usr/bin/perl5   is needed by perl-5.8.0-30
	/usr/local/bin/perl   is needed by perl-5.8.0-30
	/usr/local/bin/perl   is needed by perl-CGI-2.80-30

I don't know what to make of any of them. 

FWIW, I'm still using rpm-4.0.4-7x.18. Is that the issue?

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Chip Turner 2002-07-17 16:44:27 EDT
*** Bug 69096 has been marked as a duplicate of this bug. ***
Comment 2 Chip Turner 2002-07-17 16:50:57 EDT
I believe this is a result in local build policies defined by RPM vs those used
in our build environments.  Investigating.
Comment 3 sean 2002-07-21 09:31:39 EDT
FWIW, same sort of odd dependency in evolution:

 rpm -Fvh evol*
error: failed dependencies:
	BEGIN:VCALENDAR   is needed by evolution-1.0.8-3
Comment 4 Leonard den Ottolander 2004-04-22 12:15:40 EDT
I don't believe this was a problem for RHL 9.

CURRENTRELEASE?

Note You need to log in before you can comment on or make changes to this bug.