Bug 69036 - deletion of double width characters not properly handled (UTF-8)
deletion of double width characters not properly handled (UTF-8)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: readline (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
Depends On:
Blocks: 65252 67218
  Show dependency treegraph
 
Reported: 2002-07-17 07:53 EDT by Charles Lopes
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 11:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Lopes 2002-07-17 07:53:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Type some double width characters, some japanese kanas for example, in bash.
2.Hit backspace

	

Actual Results:  The cursor is in the middle of the last character after having
erased the right half of it.

Expected Results: The cursor should be right after the end of the previous
character.

Additional info: I'm very gratefull for #68313 to be fixed. It makes life a lot
easier. Fixing the display handling is the next logical step to make UTF-8 a
viable option. Note that the problem exists as well in EUC-JP. Except that
probably users don't mind it too much since they need anyway to hit backspace
twice to clear the character from the buffer as well. If you decide to use some
fix like #68313 for other encodings, fixing this will be required if you don't
want to upset users of east asian scripts.
Next is combining characters like ab (the arrow should be over the a). But that's
altogether another problem. I'm just mentioning it so that you're aware of it if
you decide to fix this one.
Comment 1 Phil Knirsch 2002-07-23 11:24:47 EDT
Latest readline package (4.3-1) has the fix (acording to the changelog, at it's
actually the same fix i had already included in readline-4.2a-7).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.