Bug 69038 - xscreensaver drawing debugging messages on lock window
xscreensaver drawing debugging messages on lock window
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: xscreensaver (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-07-17 08:18 EDT by Jonathan Kamens
Modified: 2007-04-18 12:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 17:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-17 08:18:17 EDT
xscreensaver-4.05-1 from rawhide.

I've got xscreensver configured to just blank the screen.  When I go to unlock,
I see messages written in yellow in the upper corner of the screen like ("PAM:
brk increased by 40K" and "xscreensaver: child process X exited with SIGTERM"
(or something like that).  These are probably debugging messages that need to go
away.
Comment 1 Jamie Zawinski 2002-07-27 03:21:47 EDT
Not a bug: you are seeing these messages because you turned on the "Verbose
Diagnostics" checkbox on the "Advanced" tab of the screensaver control panel.

Run "xscreensaver-demo" and un-check that box again.
Comment 2 Jonathan Kamens 2002-07-28 21:55:47 EDT
I have never run xscreensaver-demo before in my life.  I just ran it now and
confirmed that the "Verbose Dialognostics" [sic] box on the Advanced tab is
*not* checked.
Comment 3 Jamie Zawinski 2002-07-28 22:03:57 EDT
Well, I promise you, the verbose flag is on or you wouldn't be getting these
messages.  Did you launch xscreensaver with -v?  Is verbose set to true in your
~/.xscreensaver file or in the app-defaults file?
Comment 4 Jonathan Kamens 2002-07-28 22:12:34 EDT
No -v.  No .xscreensaver file.  No verbose xscreensaver setting in my X
resources.  I've changed nothing in my xscreensaver configuration or how I
invoke it, and yet these messages have started appearing when they were not
appearing before.

Perhaps the RPM is compiled in a way which causes these messages to appear when
they wouldn't normally.

Please do me a favor and stop treating me like an idiot (I don't know if that
was your intent, but it sure feels that way).  Take a look at how many bugs I've
filed in bugzilla.  I know a thing or two about reporting bugs.

Not to mention the fact that the first "xscreensaver" was written by me before
you even thought about writing yours :-).
Comment 5 Jamie Zawinski 2002-07-28 22:18:45 EDT
I'm not treating you like an idiot.  I'm telling you that I have no idea why you
are experiencing the things you are, and pointing out the only things that I can
think of that could be causing it.  If you're taking that personally, I can't do
anything about that...
Comment 6 Bill Nottingham 2003-02-18 16:57:21 EST
Has this ever reappeared? I can't reproduce it here.
Comment 7 Jonathan Kamens 2003-02-19 23:09:20 EST
I can't make it happen now, but I'm pretty certain I've seen the messages on my
xscreensaver window recently.  I also see this in my .xsession-errors file,
which suggests that xscreensaver is sending it to stderr, and it shouldn't be:

xscreensaver: 23:04:06: PAM: brk grew by 40K.
xscreensaver: 23:04:09: PAM: brk grew by 8K.

I just checked my settings with xscreensaver-demo, and I don't have any verbose
settings of any sort enabled.  I'm using xscreensaver-4.07-2.  Here are my
xscreensaver resources:

XScreenSaver*lock:      True
XScreenSaver*splash:    False
XScreenSaver*dpmsEnabled:       True
XScreenSaver*programs:
Comment 8 Bill Nottingham 2003-02-19 23:28:52 EST
xscreensaver does normally send that message to stderr. It implies a leak somewhere.
Comment 9 Bill Nottingham 2003-02-19 23:31:25 EST
normally, meaning 'to stderr' as opposed 'to the screen'.
Comment 10 Ray Strode [halfline] 2004-06-14 17:24:10 EDT
I can't reproduce this.  Johnathan, if it happens to you again, can
you please reopen the bug?
Comment 11 Maynard Kuona 2004-08-13 20:51:35 EDT
To reproduce it, try locking the screen, and then entering a wrong
password to unlock the screen.
Comment 12 Ken Snider 2004-11-18 23:35:34 EST
Just a "metoo" here. This *does* happen, just not reproducibly.

I came home to my system (FC2) today to see that exact message. Is
there a possibility that when drawing on a root window, that STDERR is
redirected to the screen somehow?
Comment 13 Steve Fox 2005-05-17 11:52:49 EDT
FWIW, I just experienced this exact problem with xscreensaver-4.18-4 on Fedora
Core 3. Screen is set to blank, verbose is disabled. However it did not result
from an invalid password attempt. I merely left my office for 2 minutes and it's
extremely unlikely that anyone tried to log onto my computer while I was out.

Note You need to log in before you can comment on or make changes to this bug.