Bug 69039 - xscreensaver loses first characters of my password
xscreensaver loses first characters of my password
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xscreensaver (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 72390 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-17 08:20 EDT by Jonathan Kamens
Modified: 2014-03-16 22:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 21:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-17 08:20:01 EDT
With xscreensaver-4.05-1, if the screen is locked and I start typing my password
quickly, xscreensaver loses one or more characters at the beginning of the
password.  I'm pretty certain that this didn't happen with previous versions.
Comment 1 Jamie Zawinski 2002-07-27 03:23:59 EDT
Works for me, and that code hasn't changed in quite some time.

Are you *sure* this is happening?

Run "xscreensaver-command -lock".
Be careful not to touch the mouse.
Type "x".
When the password dialog comes up, there should be one "*" in the field already.

Just tested with 4.05, worked fine....
Comment 2 Jonathan Kamens 2002-07-28 21:57:19 EDT
Yes, I'm sure this is happening.  I can make it happen over and over again.
Comment 3 Jamie Zawinski 2002-07-28 22:08:49 EDT
Well, it doesn't happen for me, so you're going to need to either give me more
hints as to how I can reproduce it here, or debug it yourself...  I don't know
what else to do.

xscreensaver/driver/lock.c, handle_typeahead() and handle_passwd_key().
xscreensaver/driver/timers.c, swallow_unlock_typeahead_events().
Comment 4 Jonathan Kamens 2002-07-28 22:17:12 EDT
Are you using the same exact version of xscreensaver that I am, i.e., the same
Red Hat RPM?  Do you have all the other same RPMs in your environment as I do,
i.e., all the current RPMs from Raw Hide?  If the answer to either of these
questions is no, then I don't think you've actually tried to reproduce the
problem in my environment.

Are you the official maintainer of xscreensaver for Red Hat?  If not, then I'm a
bit puzzled by the tone of your comments, which sound to me like you think you
"own" this bug.  As far as I know, the Red Hat developer with direct
responsibility for attempting to reproduce this bug and, if necessary, feed it
upstream to you is notting@redhat.com.

I appreciate the fact that you are trying to help.  But unless you are actually
testing in the environment about which I've reported this bug, it seems to me
that you're wasting my time more than helping me.

If the folks at Red Hat are unable to duplicate the problem in the environment
I've described, then I will debug the problem further.  But until then, I don't
think that's appropriate.  Considering that my third child is due to arrive in
four days, I'm afraid I must be a bit stingy about what I spend my free time
doing right now.
Comment 5 Bill Nottingham 2002-07-28 22:21:12 EDT
This is probably related to the patch that converts the unlock widget to gtk2 by
Jacob Berkman; the bug is probably in there.
Comment 6 Jamie Zawinski 2002-07-28 22:26:33 EDT
I am the maintainer of xscreensaver.  I don't work for Red Hat, and I don't
build, or test, their RPMs.  I read their bug database because it contains
information about my program.  I replied to your bug report in an attempt to
help you, not because I am obliged to.  If you don't want my help, feel free to
ignore it.  This is not my job, so kindly keep your attitude to yourself, 'k? 
Thanks.
Comment 7 Bill Nottingham 2002-08-23 16:51:05 EDT
*** Bug 72390 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2002-08-28 21:12:33 EDT
4.05-5 goes back to the original unlock dialog, so this should go away.
Comment 9 Jay Turner 2002-09-04 00:18:19 EDT
Reversion confirmed working with xscreensaver-4.05-6.

Note You need to log in before you can comment on or make changes to this bug.