Bug 690669 - Translation editor table shows changes which failed to save
Translation editor table shows changes which failed to save
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Sean Flanigan
Alex Eng
:
: 728415 (view as bug list)
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-03-24 21:18 EDT by Sean Flanigan
Modified: 2012-03-06 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-03-24 21:18:53 EDT
Description of problem:
  Translation editor table shows changes which failed to save

Version-Release number of selected component (if applicable):
  latest (2011-03-24)

How reproducible:


Steps to Reproduce:
1. Launch translation editor against locale, say XY
2. As project maintainer, disable locale XY for that project
3. Try to save a translation using the XY editor

Actual results:
  Cell contents assume the value entered by the user

Expected results:
  Error message, cell contents keep old value

Additional info:
Comment 1 Sean Flanigan 2011-09-07 00:33:34 EDT
Assigning to Scrum product owner for prioritisation.
Comment 2 Sean Flanigan 2012-02-10 01:07:36 EST
We should review the status of this one.
Comment 3 Ding-Yi Chen 2012-02-15 20:44:26 EST
In Zanata version 1.5-SNAPSHOT (20120215-1342).

Problem still exists, translators can still translate if they keep the webtrans open on the time the locale disable. 
It looks as if they can still save with error "An unknown error occurred". But the save did not actually succeed.

Using bookmark can still visit the document page, but no message is listed.

REASSIGNED.
Comment 4 Sean Flanigan 2012-02-27 21:10:03 EST
I've made error messages more visible: https://github.com/zanata/zanata/commit/569d8b931651fab909129bc1a217044b4096bb91

and also made notifications stay visible until dismissed: https://github.com/zanata/zanata/commit/104ed4f010f8134fc380accbcea5adfae2f7b76d

Convincing the editor table not to show the unsaved changes will have to wait until we can overhaul or replace it.
Comment 5 Alex Eng 2012-02-27 22:10:08 EST
VERIFIED on implementation on Comment 4 in Zanata version 1.5.0-alpha-3-SNAPSHOT (20120228-1154).
Comment 6 Sean Flanigan 2012-02-29 19:43:50 EST
*** Bug 728415 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.