Bug 728415 - Zanata doesnt give out a warning/error message when losing the connection
Zanata doesnt give out a warning/error message when losing the connection
Status: CLOSED DUPLICATE of bug 690669
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-04 23:55 EDT by Hedda Peters
Modified: 2013-03-03 21:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 19:43:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2011-08-04 23:55:59 EDT
Description of problem:
When working on a document on the workspace, if the user loses the connection (specifically VPN drop out in this case, internet connectivity still worked), the user is not notified in any way. Zanata still appears to accept and save changes on the current page of the workspace.

Version-Release number of selected component (if applicable):
-

How reproducible:
-

Steps to Reproduce:
1. Use a VPN connection while translating
2. then cut the VPN connection.
3.
  
Actual results:
The user can keep translating on the current page of the workspace, appears to be able to save the edited entries without problem. Only when trying to go to the next page of the same document, this won't work and the user will notice that something is wrong. After re-establishing the VPN connection and reloading the workspace, all work after the VPN drop out occured is lost of course. 

Expected results:
As soon as the connection is lost, there should be an obvious error message of some sort to notify the user that something is wrong. "Saving" an edited message should fail.

Additional info:
Comment 1 Sean Flanigan 2011-09-07 00:33:08 EDT
Assigning to Scrum product owner for prioritisation.
Comment 2 Runa Bhattacharjee 2011-09-08 09:08:31 EDT
I am not sure if this can be marked as a Zanata problem. This issue is expected to happen for any kind of web-based form, in browsers. Can this be treated for Zanata particularly?
Comment 3 Hedda Peters 2011-09-08 18:25:16 EDT
Google mail/docs etc has a better solution to this problem, so it must be possible. With Google you get a red notification at the top of the screen "unable to connect to server...trying again in x minutes..."

Zanata should do the same, rather then letting you translate a whole page in vain.
Comment 4 Sean Flanigan 2011-09-08 19:48:24 EDT
Yes, the web client keeps a connection open to the server at all times, so we should be able to detect a break somehow. (The server does.)

And at the very least we should be telling the user if we fail to save a message.  (I kind of thought we were.)

This should probably be split into two bugs, since it will probably be easier to detect "failed to save".
Comment 5 Noriko Mizumoto 2011-10-04 21:14:01 EDT
This bug has not been fixed in Zanata version 1.4 (20111003-1100).

It is specially critical when proofreading. All the changes made to the strings in the page are lost, which were already marked as 'translated' and modified for QA improvement. Can this be addressed next sprint?
Comment 6 Alex Eng 2011-10-20 20:39:38 EDT
At the moment, error message showing "Failed to update Translation Unit: row" when saving occurs without internet connection. There is no constant checking of connection.
Comment 7 Hedda Peters 2011-12-12 17:09:41 EST
This is still a problem. There is *no* warning message when attempting to save a translation without connection. Only the usual message "translation unit succesfully saved" is not being displayed, which is of course not enough to alert the user. We do need a very obvious warning message. 

I'm having a buggy VPN connection these days, and I repeatetly lose the translation of 3-4 stings, before finally realizing that my VPN connection dropped.

Using Zanata version 1.4.1 (20111006-0937) at the moment.
Comment 8 Sean Flanigan 2012-02-29 19:43:50 EST

*** This bug has been marked as a duplicate of bug 690669 ***

Note You need to log in before you can comment on or make changes to this bug.