Bug 690681 - [abrt] bridges::cpp_uno::shared::VtableFactory::initializeBlock
[abrt] bridges::cpp_uno::shared::VtableFactory::initializeBlock
Status: CLOSED DUPLICATE of bug 767708
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:c097a21fe73f2b8da94d3919ab9...
:
: 575441 652725 710237 710241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-24 22:39 EDT by nomnex
Modified: 2011-12-15 00:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-17 18:19:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (36.31 KB, text/plain)
2011-03-24 22:39 EDT, nomnex
no flags Details

  None (edit)
Description nomnex 2011-03-24 22:39:04 EDT
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/soffice.bin -quickstart -nologo -nodefault
comment: crash occured after a reboot. first time to happen. never happened before.
component: openoffice.org
crash_function: bridges::cpp_uno::shared::VtableFactory::initializeBlock
executable: /usr/lib/openoffice.org3/program/soffice.bin
kernel: 2.6.34.8-68.fc13.i686
package: openoffice.org-brand-1:3.2.0-12.35.fc13
rating: 4
reason: Process /usr/lib/openoffice.org3/program/soffice.bin was killed by signal 7 (SIGBUS)
release: Fedora release 13 (Goddard)
time: 1301019750
uid: 500

How to reproduce
-----
1. reboot system
2. ooo has crased msg
3.
Comment 1 nomnex 2011-03-24 22:39:08 EDT
Created attachment 487447 [details]
File: backtrace
Comment 2 David Tardon 2011-03-25 05:30:13 EDT
This looks like it originated in config. manager. The configmgr code has been rewritten for 3.3, because the old version was a nightmare, so it should be okay from F-14 up.
Comment 3 David Tardon 2011-03-25 05:38:47 EDT
And maybe not... I forgot that we already had a few of these "initializeBlock" crashes in the past.
Comment 4 David Tardon 2011-03-25 05:40:06 EDT
Do you have network-mounted home or any other unusual system configuration, by any chance?
Comment 5 David Tardon 2011-03-25 05:40:37 EDT
*** Bug 575441 has been marked as a duplicate of this bug. ***
Comment 6 David Tardon 2011-03-25 05:41:03 EDT
*** Bug 652725 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2011-03-25 06:27:33 EDT
Its a SIGBUS, I'd like to see what output on tail -f /var/log/messages (if any) appears between launch of OOo and final crash. So far the only ones of these that are reproducible was a disk throwing out i/o errors which fits with a SIGBUS.
Comment 8 nomnex 2011-03-27 09:14:49 EDT
(In reply to comment #4)
> Do you have network-mounted home or any other unusual system configuration, by
> any chance?

Hello, No, I don't. I am on F-13 lxde on a different machine right now. I will run the command tomorrow on the F-14 lxde notebook.

Caolon, do I just run the command $ tail -f /var/log/messages > /log.txt after logging in and before launching OOo?
Comment 9 Caolan McNamara 2011-03-28 04:28:24 EDT
tail -f /var/log/messages > /log.txt after logging in and before launching OOo

yeah, just before launching OOo, e.g.

tail -f /var/log/messages > /tmp/log.txt

you may need to do the above as root.
Comment 10 Caolan McNamara 2011-04-17 18:19:35 EDT
I'm rather convinced these are generic hardware bugs, rather than OOo/LibreOffice ones. I'm almost tempted to stick a SIGBUS handled around initializeBlock and let it then fallback to trying elsewhere, but that way probably lies madness
Comment 11 David Tardon 2011-06-03 00:35:22 EDT
*** Bug 710237 has been marked as a duplicate of this bug. ***
Comment 12 David Tardon 2011-06-03 00:35:48 EDT
*** Bug 710241 has been marked as a duplicate of this bug. ***
Comment 13 David Tardon 2011-12-15 00:21:49 EST

*** This bug has been marked as a duplicate of bug 767708 ***

Note You need to log in before you can comment on or make changes to this bug.