Bug 6913 - Updated installer died with a signal 11 near/at the end of installing RPMs
Updated installer died with a signal 11 near/at the end of installing RPMs
Status: CLOSED DUPLICATE of bug 6938
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-10 23:14 EST by Chris Siebenmann
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-02 10:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Siebenmann 1999-11-10 23:14:28 EST
We were upgrading a Dell PowerEdge 2300 dual-cpu server
from 6.0 to 6.1, using boot-RHEA-1999:044.img,
updates-RHEA-1999:045.img, and an ISO image from your ftp
site (that had previously successfully upgraded other
machines). While the machine had four disks, we pulled
three of them (the ones with user data) for the duration of
the upgrade the remaining disk 0 has all the system
partitions. The system had a nearly 100% complete RH 6.0
installation, but has lots of disk space free on all the
system partitions (more than a gig on /usr, more than 300
megs in /var, more than 50 meg in the root partition at
the end of the upgrade).

 We booted with 'text updates' at the prompt, picked all
the defaults, and did not customize the list of things to
install. The upgrade process ran through the entire set
of RPMs to upgrade, ending with zsh. After apparently
completely finishing zsh, but not moving on from the
'upgrading RPMs' progress report screen, the installation
process reported that it had died with a signal 11 and the
machine promptly went down to a halt. Alt-F keys were still
operative, and nothing showed up on consoles 2, 3, and 4
except normal messages.
Comment 1 Jay Turner 1999-11-29 15:37:59 EST
Try rebuilding the RPM databse and then running the upgrade.  We have a couple
of reports of similiar problems when running the upgrade process on a RPM
database which might be corrupt.  I am making this bug a duplicate of #6938.
Please reopen if rebuilding the database does not change the behavior that you
are seeing.

*** This bug has been marked as a duplicate of 6938 ***
Comment 2 Chris Siebenmann 1999-12-01 18:40:59 EST
I am about 90% sure that the install that died did a RPM
database rebuild at the start (I think it's standard practice).
Since we couldn't afford to leave the server half-upgraded
(and rather definetly out of service) we have long-since
kludged through the upgrade, so nothing remains at this date
to retry.

Note You need to log in before you can comment on or make changes to this bug.