Bug 6938 - Python interpreter throws SIGSEGV during upgrade procedure
Python interpreter throws SIGSEGV during upgrade procedure
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
: 6913 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-11 19:16 EST by Philip Hisley
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 11:09:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Hisley 1999-11-11 19:16:55 EST
Attempting to upgrade a running 5.2 Redhat Linux system to 6.1 using
RedHat 6.1 distribution. During the initial part of the upgrade when the
RPM database is being rebuilt, the Python interpreter throws a segment
violation:

"Python SIGSEGV Received at PC 0xb in PID 23"

The upgrade process then terminates.
Comment 1 Philip Hisley 1999-11-11 22:47:59 EST
Problem Solved.

This problem appears to be related to one of two factors:
1. The RPM database was corrupted  -or-
2. There was not enough room in the root partition to rebuild the RPM databse

To solve the problem I deleted files to make room in order to rebuild the RPM
database. I then rebuilt the RPM database from the console prompt. Upon
rebooting the system and rerunning the upgrade procedure everything went fine
-- excpet for the fact that the upgrade procedure overwrote the MBR witout
asking and clobbered my mulit-boot handler (BootMagic).

It would appear that the Python interpreter/script does not exit gracefully
upon encountering the problems indicated above.

This bug appears to be similar in nature to Bug reports 5545 and 5705.
Comment 2 Jay Turner 1999-11-29 15:11:59 EST
This issue has been forwarded to a developer for further action.
Comment 3 Jay Turner 1999-11-29 15:37:59 EST
*** Bug 6913 has been marked as a duplicate of this bug. ***
Comment 4 Jay Turner 2000-02-22 11:09:59 EST
Error handling is vastly improved in the latest installer (available in beta) so
that should help out with problems like this.

Note You need to log in before you can comment on or make changes to this bug.