Bug 691505 - Very long Dynagroup names cause stack trace - field should be limited to 100 chars
Very long Dynagroup names cause stack trace - field should be limited to 100 ...
Status: CLOSED DUPLICATE of bug 734231
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity low (vote)
: ---
: ---
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks: gwt-dynagroups rhq-uxd
  Show dependency treegraph
 
Reported: 2011-03-28 13:46 EDT by Corey Welton
Modified: 2012-01-27 16:25 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-27 10:25:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2011-03-28 13:46:33 EDT
Description of problem:
The apparent maxlength of dynagroup names is 100 characters.  A user is able to enter more than this in the field, however, and a stacktrace results.  User should be given a hard maximum of 100 in the field.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Nav to dynagroup page; create a new dynagroup or edit an existing one.
2.  In the name field, enter > 100 characters.
3.  Stack trace; view Message center error.
  
Actual results:

java.lang.RuntimeException:org.rhq.enterprise.server.resource.group.definition.exception.GroupDefinitionUpdateException:Name is limited to 100 characters
--- STACK TRACE FOLLOWS ---
org.rhq.enterprise.server.resource.group.definition.exception.GroupDefinitionUpdateException:Name is limited to 100 characters
    at Unknown.java_lang_RuntimeException_$RuntimeException__Ljava_lang_RuntimeException_2Ljava_lang_RuntimeException_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_core_java_lang_RuntimeException_1FieldSerializer_instantiate__Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_RuntimeException_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase$MethodMap_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_SerializerBase_$instantiate__Lcom_google_gwt_user_client_rpc_impl_SerializerBase_2Lcom_google_gwt_user_client_rpc_SerializationStreamReader_2Ljava_lang_String_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_$readObject__Lcom_google_gwt_user_client_rpc_impl_AbstractSerializationStreamReader_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)

Expected results:
Since the field is apparently limited to 100 chars, we should probably limit how much users can actually enter into this box.


Additional info:
Comment 1 Corey Welton 2011-03-28 13:53:40 EDT
Actually the same thing goes for Description field.  I'll include that here rather than writing up a new bug for that field.
Comment 2 Mike Thompson 2012-01-27 10:25:21 EST
I could not reproduce. I checked both the Dynagroup name and description fields with 200 character strings and then again with 50 character strings (for positive and negative test cases).
Comment 3 Ian Springer 2012-01-27 16:25:40 EST
This is a dup of https://bugzilla.redhat.com/show_bug.cgi?id=734231, which was fixed a while back.

*** This bug has been marked as a duplicate of bug 734231 ***

Note You need to log in before you can comment on or make changes to this bug.