Bug 69169 - traceback when trying to add a partition on a specific disk to fill disk
traceback when trying to add a partition on a specific disk to fill disk
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-kickstart (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
:
: 68148 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-18 12:50 EDT by Tammy Fox
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-20 23:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2002-07-18 12:50:18 EDT
Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/partWindow.py", line 187, in
on_ok_button_clicked
    rowData = self.getData()
  File "/usr/share/redhat-config-kickstart/partWindow.py", line 253, in getData
    selectDialog.hide()
NameError: global name 'selectDialog' is not defined

I selected /home, ext3, fill, ondisk hdb, and format. When I clicked OK, 
I get the above traceback, and a dialog pops up that says I must specify
a size for the partition.

It successfully let me create 2 partitions on hda (the / to fill the drive and
/boot set to 75MB) before giving me this.
Comment 1 Tammy Fox 2002-07-18 12:58:26 EDT
I fixed the traceback in CVS, but it still tells me to specify a size
even if I select fill -- the size pulldown menu is blank (even though
it is grayed out). If it is grayed out with a value, it doesn't tell me
this. Should be easy to fix.
Comment 2 Tammy Fox 2002-07-18 13:14:29 EDT
I fixed my own bug. If fill is selected, it doesn't display the dialog about
having to specify a size. Please verify in 2.3.1-1.
Comment 3 Tammy Fox 2002-07-18 22:12:45 EDT
*** Bug 68148 has been marked as a duplicate of this bug. ***
Comment 4 Jay Turner 2002-07-29 12:52:50 EDT
Fix confirmed with redhat-config-kickstart-2.3.2-3.

Note You need to log in before you can comment on or make changes to this bug.