Bug 69182 - tkinter does not exist in limbo
tkinter does not exist in limbo
Status: CLOSED DUPLICATE of bug 70896
Product: Red Hat Public Beta
Classification: Retired
Component: python (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-18 13:57 EDT by Tom "spot" Callaway
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 05:20:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2002-07-18 13:57:30 EDT
Description of Problem:

tkinter does not exist in limbo

Version-Release number of selected component (if applicable):

n/a

This isn't so much of a problem that it doesn't exist, the deprecation of
tkinter is fine by me, but rather that nothing explicitly obsoletes it. This
breaks dist upgrades unnecessarily. Having the base tk package obsolete tkinter
would resolve this concern.

Resolution:

Add Obsoletes: tkinter to the Limbo tk spec file.
Comment 1 Bill Nottingham 2002-07-20 23:56:10 EDT
I really don't like the idea of obsoleteing packages when their functionality
isn't replaced.
Comment 2 Need Real Name 2002-07-29 23:55:05 EDT
PySol uses tkinter and this is a great application. 
Please bring tinker back (ref  #68845)
Comment 3 Jay Berkenbilt 2002-08-05 21:41:48 EDT
I have many applications that now no longer work since they depend upon Tkinter.
 As far as I know, this is still the most portable way to write a gui in python.
 pygtk does not work on non-Unix platforms, to my knowledge.

I'm sad that Tk isn't installed by default, but I'm even sadder that Tkinter is
gone.  Please explain the reasoning for this.  Also, I'm confused by bug 69838
which seems to imply existence of something called tkinter2.  This existed in
RedHat 7.3 (thus leading me to think that Tkinter would be around in whatever
release switched Python to version 2.x).

I would switch the severity of this to high since there is no workaround, but I
can't do that since I am not the poster.
Comment 4 Jens Petersen 2002-08-07 05:20:53 EDT
tkinter used to be part of python2 in Valhalla.  Assigning to python owner.
Comment 5 Mike McLean 2002-08-07 15:40:57 EDT

*** This bug has been marked as a duplicate of 70896 ***

Note You need to log in before you can comment on or make changes to this bug.