Bug 69207 - losetup doesn't understand des encryption
losetup doesn't understand des encryption
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: util-linux (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
: 70002 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-18 19:22 EDT by Kirk
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 10:33:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirk 2002-07-18 19:22:19 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
after creating a block file (Following the loopback encryption howto), tying to issue the following 
command: 
losetup -e des /dev/loop3 /path/tofile 
gives 
ioctl: LOOP_SET_STATUS: Invalid Argument 
 
using -e xor instead of -e des lets it complete.  From what I can gather, this means that the 
util-linux doesn't contain some patches that make the des encryption work. 
 
Version-Release number of selected component (if applicable):  2.11r-3 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.  losetup -e des /dev/loop3 /path/tofile (created by dd) 
2.  enter a password 
3.enter a hex offset 
	 
 
Actual Results:  error:  ioctl: LOOP_SET_STATUS: Invalid Argument 
 
Expected Results:  the system should have mounted the file via the lookback device 
encrypted with DES. 
 
Additional info:
Comment 1 Kirk 2002-07-18 20:00:41 EDT
looks like the actual rpm is named losetup, but that isn't a component available
to select.
Comment 2 Elliot Lee 2002-08-02 10:33:44 EDT
*** Bug 70002 has been marked as a duplicate of this bug. ***
Comment 3 Elliot Lee 2002-08-02 10:40:59 EDT
losetup comes from the util-linux source package.

I'm not going to add anything in this area that's not in the upstream package, so you need 
to talk to the util-linux maintainer upstream (util-linux@math.uio.no) - there are multiple 
patchsets to implement loopback encryption support, and none of them had been 
submitted directly to him last I heard.
Comment 4 Kirk 2002-08-02 23:45:15 EDT
According to traffic on the limbo-list, the entire crytoapi has been added to
the rawhide kernel 2.4.18-7.85...wouldn't this require changes to the util-linux
package (losetup) to put it all together?
Comment 5 Elliot Lee 2002-08-03 22:14:47 EDT
Yes, but my earlier comments still stand (the changes will have to come from upstream).
Comment 6 Kirk 2002-08-05 09:50:28 EDT
I contacted Andries at the email address you provided, he responded quickly. 
I'm sure I don't understand the issues involoved, but I think having all of this
working in Limbo/8.0 or even 8.1 would be a huge plus for Redhat.  Here is the
snippet:

>> plans to integrate the cryptoapi patches?

>Yes.

>> when?

>Long ago the obstacle was copyrights. People sent me
>patches that could not be distributed because there
>was copyrighted material.
>Now there are at least two sets of crypto patches,
>the "international crypto patch" and the patch
>maintained by Jari Ruusu.
>Don't know whether the former is considered dead.
>Some time ago I tried to contact A. Kjeldaas in vain.


>Andries

Note You need to log in before you can comment on or make changes to this bug.