Bug 70002 - losetup doesn't understand des encryption
Summary: losetup doesn't understand des encryption
Status: CLOSED DUPLICATE of bug 69207
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-28 17:43 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-28 17:55:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-07-28 17:43:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
after creating a block file (Following the loopback encryption howto), tying to 
issue the following 
command: 
losetup -e des /dev/loop3 /path/tofile 
gives 
ioctl: LOOP_SET_STATUS: Invalid Argument 
 
using -e xor instead of -e des lets it complete.  From what I can gather, this 
means that the 
util-linux doesn't contain some patches that make the des encryption work. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  losetup -e des /dev/loop3 /path/tofile (created by dd) 
2.  enter a password 
3.enter a hex offset 

Actual Results:  error:  ioctl: LOOP_SET_STATUS: Invalid Argument 

Expected Results:  the system should have mounted the file via the lookback 
device 
encrypted with DES. 


Additional info:

Comment 1 Elliot Lee 2002-08-02 14:33:49 UTC

*** This bug has been marked as a duplicate of 69207 ***


Note You need to log in before you can comment on or make changes to this bug.