Bug 692154 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED DUPLICATE of bug 783112
Product: Fedora
Classification: Fedora
Component: memcached (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Lindner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-03-30 11:11 EDT by Michał Piotrowski
Modified: 2012-02-07 01:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 01:07:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
memcached.service (259 bytes, text/plain)
2011-03-30 11:12 EDT, Michał Piotrowski
no flags Details
Native systemd service file memchached (285 bytes, text/plain)
2011-07-11 04:47 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Michał Piotrowski 2011-03-30 11:11:20 EDT
The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability
Comment 1 Michał Piotrowski 2011-03-30 11:12:04 EDT
Created attachment 488789 [details]
memcached.service
Comment 2 Matthias Saou 2011-07-11 04:24:39 EDT
I haven't looked a lot into systemd yet, but after a quick look at the memcached.service file you attached I do have a question : Shouldn't there be something in order to ensure memcached is started before any locally installed web server?

I think the most widely used setup for memcached involves web server daemons, so even though nothing can be done for remote ones (i.e. on other machines), we should at least try to make sure any local web server daemon has it available initially.
Comment 3 Jóhann B. Guðmundsson 2011-07-11 04:47:28 EDT
Created attachment 512153 [details]
Native systemd service file memchached

Added Before=http-daemon.target so if any web daemon is correctly configured this will be started before those will. 

I think that should suffice for memcached and if not we should add memcached.service to the After= line in those web daemons
Comment 4 Paul Lindner 2012-02-07 01:07:24 EST

*** This bug has been marked as a duplicate of bug 783112 ***

Note You need to log in before you can comment on or make changes to this bug.