This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 783112 - Provide native systemd service
Provide native systemd service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: memcached (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Lindner
Fedora Extras Quality Assurance
:
: 692154 (view as bug list)
Depends On:
Blocks: 751869 816135 818958
  Show dependency treegraph
 
Reported: 2012-01-19 07:12 EST by Jóhann B. Guðmundsson
Modified: 2012-05-09 06:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 11:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd unit for memcached (279 bytes, text/plain)
2012-01-19 07:12 EST, Jóhann B. Guðmundsson
no flags Details
tmpfile to generate the pid directory on each startup (44 bytes, text/plain)
2012-01-19 07:13 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2012-01-19 07:12:13 EST
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2012-01-19 07:12:54 EST
Created attachment 556257 [details]
Native systemd unit for memcached
Comment 2 Jóhann B. Guðmundsson 2012-01-19 07:13:49 EST
Created attachment 556258 [details]
tmpfile to generate the pid directory on each startup
Comment 3 Jóhann B. Guðmundsson 2012-01-19 07:18:32 EST
These are new unit files and updated to the current systemd implementation bug 692154 should be closed as duplicate of this one. 

This unit file is upstream-able thus usable between distribution. 

The reference to /etc/sysconfig/file has been dropped since it's Fedora/Red Hat specific. 

If users/adminstrators want to add options to daemon startup they should copy the unit file to /etc/systemd/system directory and add those options there. 

Now let's try to get this shipped in F17 shall we...
Comment 4 Paul Lindner 2012-02-07 01:07:24 EST
*** Bug 692154 has been marked as a duplicate of this bug. ***
Comment 5 Jóhann B. Guðmundsson 2012-02-12 16:59:24 EST
Ping
Comment 6 Jon Ciesla 2012-04-19 15:01:52 EDT
Paul, any objection to my making this change?
Comment 7 Joe Orton 2012-04-19 15:14:12 EDT
Does that:

Before=http-daemon.target

actually do what you want?  It seems to be some legacy target for use with the init script?  (Happy to be proven wrong!)
Comment 8 Jon Ciesla 2012-04-19 15:28:58 EDT
It probably does, but I think httpd.service is better.
Comment 9 Jon Ciesla 2012-04-24 10:05:59 EDT
Ping?
Comment 10 Jon Ciesla 2012-05-04 09:50:10 EDT
I'll do this today if noone objects in the interim.
Comment 11 Jon Ciesla 2012-05-04 11:55:49 EDT
Done.  Made modifications for sysconfig support, corrected the pidfile location, etc.

Note You need to log in before you can comment on or make changes to this bug.