Bug 692231 - [fedora-logos] should obsolete gnome-logos
Summary: [fedora-logos] should obsolete gnome-logos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-logos
Version: 15
Hardware: noarch
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-30 18:29 UTC by Joachim Frieben
Modified: 2011-04-02 06:00 UTC (History)
3 users (show)

Fixed In Version: fedora-logos-15.0.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-02 06:00:06 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2011-03-30 18:29:26 UTC
Description of problem:
After installing F15 from the TC1 boot.iso, fedora-logos is -not- installed, only gnome-logos-2.91.92-2.fc15. Accordingly, grub is not themed, and plymouth is not working correctly. Attempting to update to the latest gnome-icon-theme-2.91.92-6.fc15 and to install fedora-logos-15.0.0-1.fc15 (which provides system-logos as does gnome-logos) at the same time fails:

% yum localinstall fedora-logos-15.0.0-1.fc15.noarch.rpm gnome-icon-theme-2.91.92-6.fc15.noarch.rpm gnome-icon-theme-legacy-2.91.92-6.fc15.noarch.rpm
Loaded plugins: langpacks, refresh-packagekit
Setting up Local Package Process
Examining fedora-logos-15.0.0-1.fc15.noarch.rpm: fedora-logos-15.0.0-1.fc15.noarch
Marking fedora-logos-15.0.0-1.fc15.noarch.rpm to be installed
Examining gnome-icon-theme-2.91.92-6.fc15.noarch.rpm: gnome-icon-theme-2.91.92-6.fc15.noarch
Marking gnome-icon-theme-2.91.92-6.fc15.noarch.rpm as an update to gnome-icon-theme-2.91.92-2.fc15.noarch
Examining gnome-icon-theme-legacy-2.91.92-6.fc15.noarch.rpm: gnome-icon-theme-legacy-2.91.92-6.fc15.noarch
Marking gnome-icon-theme-legacy-2.91.92-6.fc15.noarch.rpm as an update to gnome-icon-theme-legacy-2.91.92-2.fc15.noarch
Resolving Dependencies
--> Running transaction check
---> Package fedora-logos.noarch 0:15.0.0-1.fc15 will be installed
---> Package gnome-icon-theme.noarch 0:2.91.92-2.fc15 will be updated
--> Processing Dependency: gnome-icon-theme = 2.91.92-2.fc15 for package: gnome-logos-2.91.92-2.fc15.noarch
---> Package gnome-icon-theme.noarch 0:2.91.92-6.fc15 will be an update
---> Package gnome-icon-theme-legacy.noarch 0:2.91.92-2.fc15 will be updated
---> Package gnome-icon-theme-legacy.noarch 0:2.91.92-6.fc15 will be an update
--> Processing Conflict: gnome-logos-2.91.92-2.fc15.noarch conflicts fedora-logos
--> Finished Dependency Resolution
Error: Package: gnome-logos-2.91.92-2.fc15.noarch (@fedora)
           Requires: gnome-icon-theme = 2.91.92-2.fc15
           Removing: gnome-icon-theme-2.91.92-2.fc15.noarch (@fedora)
               gnome-icon-theme = 2.91.92-2.fc15
           Updated By: gnome-icon-theme-2.91.92-6.fc15.noarch (/gnome-icon-theme-2.91.92-6.fc15.noarch)
               gnome-icon-theme = 2.91.92-6.fc15
Error: gnome-logos conflicts with fedora-logos
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):
fedora-logos-15.0.0-1.fc15

How reproducible:
Always.

Steps to Reproduce:
1. Run 'yum localinstall fedora-logos-15.0.0-1.fc15.noarch.rpm gnome-icon-theme-2.91.92-6.fc15.noarch.rpm gnome-icon-theme-legacy-2.91.92-6.fc15.noarch.rpm'.
  
Actual results:
Installing said packages fails, see error message reported above.

Expected results:
Installing said packages succeeds removing gnome-logos-2.91.92-2.fc15 from the system.

Additional info:
None.

Comment 1 Fedora Update System 2011-03-30 19:25:37 UTC
fedora-logos-15.0.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fedora-logos-15.0.0-2.fc15

Comment 2 Andre Robatino 2011-03-30 21:20:32 UTC
This appears to be a duplicate of bug 692029 - although this bug has more info so maybe that one should be marked as a dupe instead.

Comment 3 Fedora Update System 2011-03-31 03:57:23 UTC
Package fedora-logos-15.0.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-logos-15.0.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/fedora-logos-15.0.0-2.fc15
then log in and leave karma (feedback).

Comment 4 Tim Flink 2011-04-01 17:30:55 UTC
Discussed at the 2011-04-01 blocker bug meeting. Rejected as a blocker as it only affects people who installed during a specific time period.

Comment 5 Fedora Update System 2011-04-02 06:00:01 UTC
fedora-logos-15.0.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.