Bug 69227 - bash shell in mc hangs or mc refuses to start for normal user
bash shell in mc hangs or mc refuses to start for normal user
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Aaron Brown
:
: 69321 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-19 06:02 EDT by Leonard den Ottolander
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 13:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leonard den Ottolander 2002-07-19 06:02:25 EDT
Description of Problem:
 Everything install (RH 7.1), all updates applied. mc is quirky. No problems as
root, but for local users shell commands (bash) frequently hang mc, or mc even
refuses to start up at all. No filesystem errors, no quota set, 300 MB free disk
space.
 Maybe this is a problem with the new glibc? Possibly a package rebuild against
the new glibc solves the problem?


Version-Release number of selected component (if applicable):
mc-4.5.51-32
bash-2.04-21
glibc-2.2.4-24
kernel-2.4.9-34 (i686)

How Reproducible:
 

Steps to Reproduce:
1. Start mc as normal user (everything install + all updates)
2. If mc starts up at all, run some shell commands
3. 

Actual Results:
 mc refuses to start up, or hangs when running shell commands as normal user. No
problems as root.


Expected Results:
 Being able to use shell commands in mc


Additional Information:
Comment 1 Leonard den Ottolander 2002-07-20 21:06:11 EDT
Some digging rendered the following result:
 The problem seems to be an incompatibilty with util-linux-2.11f-17. If I
downgrade util-linux to 2-10s-12 the problem dissapears. Note that the problem
does not always appear for each user, and when it appears it takes different
forms: either mc hangs when running shell commands or after pressing ^o a couple
of times, or mc refuses to start up at all. In either case mc has to be killed
using kill <pid>.
 It's nice this issue might be fixed in Rawhide (see bug #57538), but maybe it is
a good idea to release an upgraded util-linux package for 7.1? No need to
upgrade to Rawhide due to a broken update is it?
Comment 2 Leonard den Ottolander 2002-07-21 21:42:24 EDT
 The only solution seems to be upgrading to RH 7.3's mc-4.5.55-5 (and dev-3.3-4)
(or downgrading util-linux to 2.10s-12).
 Upgrading to util-linux-2.11n-12 didn't make a difference, nor recompiling mc on
the updated system. Very weird util-linux seems to break these versions of mc
(4.5.51-32 & -36) on RH 7.1, but updating util-linux doesn't solve anything.
 By the way, what happened to mcserv and gmc in 7.3?
Comment 3 Havoc Pennington 2002-07-21 22:08:01 EDT
I guess this is a util-linux issue?
Comment 4 Elliot Lee 2002-07-22 11:23:44 EDT
While I'm not denying the effects you saw by changing util-linux versions, I don't see how 
util-linux is involved.
Comment 5 Leonard den Ottolander 2002-07-22 12:12:47 EDT
I don't know how exactly this problem relates to util-linux, but fact of the
matter is that it's the upgrade to util-linux-2-11f-17 (or 2-11n-12 for that
matter) that breaks mc. Downdating util-linux to 2-10s-12 and leaving all the
other updates in place makes the problem with mc dissappear. So maybe after all it
is a bug in mc, but for sure it is somehow related to util-linux. Now you tell me
why ;). I haven't been able to figure it out in the last few days, and mind you,
I've spend some time investigating this bugger. Maybe I'll look in to it a little
more.
Comment 6 Elliot Lee 2002-07-22 12:28:00 EDT
*** Bug 69321 has been marked as a duplicate of this bug. ***
Comment 7 Leonard den Ottolander 2002-07-22 13:02:20 EDT
/bin/login seems to be the culprit:
# rpm -q util-linux
util-linux-2-10s-12
# cp /bin/login /bin/login.000
# rpm -Uv util-linux-2-11f-17
# mv /bin/login /bin/login.001
# cp /bin/login.000 /bin/login
Now the problem does not occur.
Comment 8 Elliot Lee 2002-07-22 13:08:21 EDT
OK, perhaps mc is broken for invoking /bin/login - it should probably just run the shell, yuk. 
At least I know where the problem is, thanks!
Comment 9 Leonard den Ottolander 2002-07-22 13:19:56 EDT
You're welcome :-). Note that the problem does not exist any more in mc-4.5.55-5
(7.1 + updates + dev-3.3-4 + mc-4.5.55-5 works fine).
Comment 10 Elliot Lee 2002-07-22 13:38:21 EDT
oh, this means I can ignore the bug because rawhide fixes it! :)

This probably isn't an issue that we'd release an erratum for, and since it sounds to be 
fixed by the mc in rawhide (and indeed the one in 7.3), there shouldn't be any problems left 
to resolve I hope.
Comment 11 Leonard den Ottolander 2002-07-22 13:58:06 EDT
Hm. I don't know about Red Hat's policy about supporting older releases, but it
seems a bit strange that you have a bug fix that creates a new problem and there
is not even an announcement on how to solve it. But hey, that's for you to decide
about ;).
By the way, changing this back to mc if that is still possible.
Leaves me with the unanswered question what happened to gmc & mcserv...

Note You need to log in before you can comment on or make changes to this bug.