Bug 692816 - automount does not perform a sanity check of server name in configuration
Summary: automount does not perform a sanity check of server name in configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autofs
Version: 6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On: 692813
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-01 09:46 UTC by Siddhesh Poyarekar
Modified: 2015-09-14 00:22 UTC (History)
2 users (show)

Fixed In Version: autofs-5.0.5-32
Doc Type: Bug Fix
Doc Text:
Clone Of: 692813
Environment:
Last Closed: 2011-12-06 17:58:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch - fix sanity checks for brackets in server name (1.69 KB, patch)
2011-08-15 04:15 UTC, Ian Kent
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1723 normal SHIPPED_LIVE autofs bug fix and enhancement update 2011-12-06 01:02:10 UTC

Description Siddhesh Poyarekar 2011-04-01 09:46:46 UTC
+++ This bug was initially created as a clone of Bug #692813 +++

Created attachment 489333 [details]
Do not consider escaped '(' as a separator and do not crash if '(' does not find its ')'

Description of problem:
automount does not perform a sanity check of server name in configuration. Unmatched brackets in the configuration can cause automount to crash.

Also, with replication using wildcard '&', the same code crashes when the requested mount point contains an escaped bracket '\('.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

=======================
For the wildcard:

# echo '/jobman/tmp1 file /etc/auto.jobman.tmp1 -nodev,nosuid,intr,soft,retry=3,private' > /etc/auto.master 

# echo '* -nodev,nosuid,intr,soft,retry=10,proto=tcp &:/tmp1' > /etc/auto.jobman.tmp1

# service autofs restart

# df /jobman/tmp1/bl\(ah

=======================
For the configuration error:

# echo '/jobman/tmp1 file /etc/auto.jobman.tmp1 -nodev,nosuid,intr,soft,retry=3,private' > /etc/auto.master 

# echo '* -nodev,nosuid,intr,soft,retry=10,proto=tcp hostname(2:/tmp1' > /etc/auto.jobman.tmp1

# service autofs restart

# df /jobman/tmp1/foo
=======================

Actual results: Crash

Expected results: No crash

Additional info:

Attached patch that should fix both crashes.

Comment 1 Ian Kent 2011-08-15 04:15:31 UTC
Created attachment 518215 [details]
Patch - fix sanity checks for brackets in server name

Comment 3 yanfu,wang 2011-09-26 10:21:28 UTC
hi Ian,
There's typo in bz692816/runtest.sh, I corrected it and checked it in cvs now. FYI, in order to let you sync with cvs while you develop the regression testsuite, thanks.
./runtest.sh: command substitution: line 28: unexpected EOF while looking for matching `''
./runtest.sh: command substitution: line 29: syntax error: unexpected end of file

I've rescheduled jobs and will update results later...

Comment 5 errata-xmlrpc 2011-12-06 17:58:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1723.html


Note You need to log in before you can comment on or make changes to this bug.