Bug 693028 - Use g_get_user_cache_dir() for debug output
Use g_get_user_cache_dir() for debug output
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
: 821524 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-02 01:16 EDT by jmccann
Modified: 2015-01-14 18:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 08:29:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmccann 2011-04-02 01:16:38 EDT
It would be nice to use g_get_user_config_dir() instead of home directory to store configuration files.  In accordance with the XDG base directory spec.  http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html

This has a number of benefits including making it much easier to migrate data.
Comment 1 Cole Robinson 2012-02-06 17:54:20 EST
The only thing virt-manager stores in home is debug output, so we probably want get_user_cache_dir
Comment 2 Cole Robinson 2012-05-16 11:24:55 EDT
*** Bug 821524 has been marked as a duplicate of this bug. ***
Comment 3 jmccann 2012-05-16 13:03:14 EDT
I don't think writing log files to home is a good idea either. I think we want this information to end up in the systemd journal.
Comment 4 faispasierch 2012-11-21 07:55:01 EST
* ping
Comment 5 Cole Robinson 2012-11-27 11:34:10 EST
(In reply to comment #4)
> * ping

If you want this to be solved quicker, please provide a patch.

I am planning of fixing this when we port to gtk3, since that will already be disruptive enough that it will be a good time to change directory locations.
Comment 6 faispasierch 2012-11-30 10:42:16 EST
Just a question, when do you plan to port to GTK3?
Comment 7 Cole Robinson 2012-11-30 13:36:11 EST
Most of the work is done but its not upstream yet. I'm hoping to get it upstream before the end of the year, with a release soon after.
Comment 8 faispasierch 2013-08-29 08:56:55 EDT
Is this bug still open?
Comment 9 Cole Robinson 2013-10-01 08:29:07 EDT
Fixed upstream now

Note You need to log in before you can comment on or make changes to this bug.