Bug 821524 - Use XDG dirs instead of $HOME
Use XDG dirs instead of $HOME
Status: CLOSED DUPLICATE of bug 693028
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 15:26 EDT by jmccann
Modified: 2015-01-14 18:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 11:24:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.52 KB, patch)
2012-05-16 11:05 EDT, Javier Hernandez
no flags Details | Diff

  None (edit)
Description jmccann 2012-05-14 15:26:49 EDT
We currently store information in the home directory. It would be better to use the directories defined in the XDG Base Directory specification.

https://live.gnome.org/GnomeGoals/XDGConfigFolders
Comment 1 Javier Hernandez 2012-05-16 11:05:48 EDT
Created attachment 584997 [details]
proposed patch

Here's a proposed patch

Cheers!
Comment 2 Cole Robinson 2012-05-16 11:24:55 EDT
Javier, thanks for the patch, but it's not exactly what mccann meant. I think he means moving ~/.virt-manager to ~/.local/share or similar. That would mean actual doc changes as well.

Either way this issue was already filed

*** This bug has been marked as a duplicate of bug 693028 ***

Note You need to log in before you can comment on or make changes to this bug.