Bug 69315 - General Gnome2 slowness
General Gnome2 slowness
Status: CLOSED DUPLICATE of bug 74910
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-07-20 14:57 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output from strace when running evolution from the command line (GZIP'd) (46.72 KB, application/octet-stream)
2002-07-22 12:52 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-20 14:57:50 EDT
Description of Problem:
Not really sure what to log this against...

The basic problem is that doing anything Gnome related seems to take forever.
This is from starting up gnome itself, to starting anything vaguely gnome
related. There are exceptions, and these appear to be generic X applications,
such as mozilla, and VNC.

Examples: Gnome startup - 2 mins, Evolution startup 2 mins, Terminal startup 30

Once the applications are running they behave properly, and are no longer slow.
For some reason it just seems to be loading of the applications which is the

The system did not do this the very first time it was booted after installation,
but since then has done so. I have tried removing all gnome configs from the
users directory, and clearing out the /tmp directory, but nothing seems to help.

Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
1. start gnome
2. do something

Actual Results:
Applications take far too long to start

Expected Results:
Should be quicker than this

Additional Information:
Machine specs:
   Dual Athlon MP 2000,
   ASUS A7M-266D,
   120GB IBM Deskstar HD,

I have tried the system will all DMA options both on and off, so it doesn't
appear to be the speed of the hard drive or anything like that.
Comment 1 Bill Nottingham 2002-07-21 00:37:45 EDT
What kernel are you running?
Comment 2 Havoc Pennington 2002-07-22 08:21:13 EDT
Try "strace -t -f -o output slowapp" and then we can analyze "output"
Comment 3 Need Real Name 2002-07-22 09:05:33 EDT
I'm using the "default" SMP kernel that shipped with the Limbo beta - I've not
rebuilt it or anything.
Comment 4 Need Real Name 2002-07-22 12:37:47 EDT
Actual kernel RPM is kernel-smp-2.4.18-5.58, like I said, I've not recomipled
it. Out of the box, as it were.
Comment 5 Need Real Name 2002-07-22 12:52:37 EDT
Created attachment 66327 [details]
output from strace when running evolution from the command line (GZIP'd)
Comment 6 Need Real Name 2002-07-22 12:53:38 EDT
Can't seem to do an strace from starting X, as X doesn't seem to like it...
Comment 7 Havoc Pennington 2002-07-22 15:14:10 EDT
Some stuff in the strace looked like you may be having issues with NIS.
Try switching to local passwd file temporarily perhaps.
Comment 8 Need Real Name 2002-07-23 00:18:39 EDT
NIS isn't enabled. In the Authentication settings I only have:

Use Shadow Passwords
Use MD5 Passwords
Enable SMB Support
Comment 9 Havoc Pennington 2002-07-23 00:57:35 EDT
OK, I was going by the fact that it read a file with NIS in the name, then 
got stuck for a bit.

Maybe it's the SMB thing? I'm not sure what that does authentication-wise.
Comment 10 Need Real Name 2002-07-23 15:46:42 EDT
Tried switching off the SMB authentication, but it seems to have no effect on
startup times.
Comment 11 Need Real Name 2002-08-04 05:18:58 EDT
This seems to be related to the hostname and DNS resolution.

My machine name is deepthought and my DNS 'name' is cyberdine.com

If I leave the machines' hostname at just deepthought X and Gnome run as fast as
I would expect. As soon as I add the .cyberdine.com suffix the system completely
slows down.

If I put in an incorrect domain name, eg deepthought.com then x just will not
start at all.
Comment 12 Need Real Name 2002-08-04 05:19:22 EDT
This is also present in limbo beta 2.
Comment 13 Havoc Pennington 2002-08-04 11:45:14 EDT
So is "nslookup `hostname`" slow when gnome is slow?

most gnome apps do indeed do the equivalent of that on startup.
Comment 14 Havoc Pennington 2002-12-13 21:34:04 EST
Pretty much the same DNS issue as #74910 I would say.

*** This bug has been marked as a duplicate of 74910 ***
Comment 15 Red Hat Bugzilla 2006-02-21 13:49:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.