Bug 74910 - Installer shouldn't use dhcp hostname by default.
Installer shouldn't use dhcp hostname by default.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature, Triaged
: 69315 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2002-10-02 14:49 EDT by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 15:33:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2002-10-02 14:49:06 EDT
When we start X the user is warned if there is no DNS for their hostname. The
message doesn't tell you to use the GUI tools and there isnt a box on the dialog
to launch the GUI tool or simply an option to get a form to fix it up.
Comment 1 Havoc Pennington 2002-10-02 15:55:57 EDT
I don't personally understand this issue well enough to know what
we need to offer to fix (or if it can be autofixed). If it can be autofixed we
could maybe just do so without asking (or just get it right in the first place).
Comment 2 Elliot Lee 2002-10-02 16:02:46 EDT
The right fix depends on the factors beyond the local host. Sometimes the 'right fix' lies in 
the DNS database on some other server (to make matching forward & reverse entries), 
while other times it can involve adding the FQDN and/or hostname onto the 127.0.0.1 line 
in /etc/hosts. I can't remember the third case, but deciding between the three cases 
requires a human.

Having a button to launch network configuration would be a good thing but would need the 
window manager running, which it isn't.
Comment 3 Alan Cox 2002-10-02 16:17:06 EDT
Could we run the window manager then kick it off, or run it under the mini
window mangler ?
Comment 4 Owen Taylor 2002-10-02 16:17:30 EDT
I guess we could check to see if /etc/hosts corforms to the Red Hat
standard, and if it doesn't do it, run a user-helpered tool
to fix it. 

I'm not sure what the Red Hat standard is currently, though.

What was fix you ended up doing, Alan?
Comment 5 Alan Cox 2002-10-02 16:25:37 EDT
I added the names to the 127.0.0.1 entry. That had old names from before I set
the hostname. Once that was done all was fine. It is a user intervention item in
many cases because its just as possible you want to know and set up the missing
DNS records that way
Comment 6 Lee Wilson 2002-10-10 18:18:54 EDT
I have had this happen on my box when I select DHCP during a fresh "Personal 
Desktop" installation.

When DHCP is selected as the network card's means of get an IP you are not 
prompted for a hostname, consequently none gets added during the install.

Could it not be made to just use a default hostname, something 
like "redhat.localdomain".  I believe during debian installation it uses this 
as a default if you don't want to choose it yourself.

This problem should be easily enough fixed (as someone else has mentioned 
above) by setting the hostname correctly in "/etc/sysconfig/network" and also 
adding the appropriate entry to "/etc/hosts".

My first impressions of RH8 is that it is more designed for the new Linux user 
so in a similair vain we should be looking for a way for this to be resolved 
automatically rather the relying on the user to user it out.

Apologies if I have just waffled on about something completely wrong.
Comment 7 Havoc Pennington 2002-12-13 21:30:50 EST
I'm all for fixing this longstanding issue but my knowledge of network 
configuration is near zero, so I think we should reassign the bug 
to someone with a clue. I'll write GUI for it if someone clearly specifies
what the GUI should do.
Comment 8 Havoc Pennington 2002-12-13 21:34:07 EST
*** Bug 69315 has been marked as a duplicate of this bug. ***
Comment 9 Julien Olivier 2003-12-10 03:29:42 EST
I just want to talk about my personal experience:

I have a laptop connected to an ADSL ethernet modem. I set up my
internet connection, during the install, so that it uses DHCP to
determine the IP address and the hostname.

When I first log in using GDM, GNOME (which is launched by GDM) warns
me that my hostname can't be found (or is incorrect...) and tells me
to add "dhcppc0" (the hostname given by my ADSL modem) to /etc/hosts.

I added it to /etc/hosts (on the 127.0.0.1 line) and all was OK then.

So my guess is that, for most users, a simple solution is to
automatically add the hostname to /etc/fstab when the eth0 connection
is started. That's only my end-user point of view though. I don't know
which problems that could imply. What I know, however, is that it
works automatically on Windows XP. So there must be a solution to this
problem.
Comment 10 Ray Strode [halfline] 2005-05-12 11:48:33 EDT
Hi,
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)
Comment 11 Ray Strode [halfline] 2005-05-31 14:22:16 EDT
Hi,

So I talked to Elliot about this a couple of weeks ago.  We do need a hostname
that maps to an ip address for two cases: ORBit and X auth cookies.  The
hostname given doesn't have to be externally resolvable or have any significance
outside of the machine it's working on.  

The name does get shown to the user in various places, so using whatever name a
random ISP's dhcp server gives is a bad idea.

Ideally when the user installs Fedora, the installer would ask the user "What
name do you want to give to your computer?" or something and then would
normalize the input into a legal hostname.  An entry for this could
automatically be added to /etc/hosts and all programs that depend on hostnames
that are forward and reverse resolvable should have no more problems.

For weird cases like lab setups where it still might be useful to get the
hostname from dhcp, the admin can always just change /etc/sysconfig/network or
whatever.
Comment 12 Jeremy Katz 2005-06-07 15:33:45 EDT
I think we actually handle this properly now.  The installer asks which you want
to do and defaults to DHCP if you're using DHCP.  But the initscripts also do
the right thing of falling back to localhost as your hostname if you don't get a
hostname via DHCP and asked for that.

Note You need to log in before you can comment on or make changes to this bug.