Bug 693177 - akonadi no longer starts after KDE 4.6 update on F14
Summary: akonadi no longer starts after KDE 4.6 update on F14
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: akonadi
Version: 14
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: kde-4.6
TreeView+ depends on / blocked
 
Reported: 2011-04-03 11:42 UTC by Christoph Wickert
Modified: 2012-06-27 23:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-27 11:55:24 UTC


Attachments (Terms of Use)
Console output when launching kontact (12.80 KB, text/plain)
2011-04-08 08:36 UTC, Christoph Wickert
no flags Details


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 268120 None None None Never

Description Christoph Wickert 2011-04-03 11:42:07 UTC
Description of problem:
After updating KDE to 4.6.1 on F14 yesterday, akonadi no longer is able to start. I cannot use kontact any longer.

Version-Release number of selected component (if applicable):
kdebase-4.6.1-3.fc14.x86_64
kdebase-libs-4.6.1-3.fc14.x86_64
kdebase-runtime-4.6.1-1.fc14.x86_64
kdebase-runtime-flags-4.6.1-1.fc14.noarch
kdebase-runtime-libs-4.6.1-1.fc14.x86_64
kde-filesystem-4-35.fc13.noarch
kde-l10n-4.6.1-1.fc14.1.noarch
kde-l10n-German-4.6.1-1.fc14.1.noarch
kdelibs3-3.5.10-24.fc14.x86_64
kdelibs-4.6.1-5.fc14.x86_64
kdelibs-common-4.6.1-5.fc14.x86_64
kdepim3-libs-3.5.10-3.fc13.x86_64
kdepim-4.4.10-2.fc14.x86_64
kdepim-libs-4.4.10-2.fc14.x86_64
kdepimlibs-4.6.1-1.fc14.x86_64
kdepimlibs-akonadi-4.6.1-1.fc14.x86_64
kdepim-runtime-4.4.10-2.fc14.x86_64
kdepim-runtime-libs-4.4.10-2.fc14.x86_64
kde-settings-4.5-11.fc14.noarch
kdeutils-minimal-4.6.1-2.fc14.x86_64
kdeutils-minimal-libs-4.6.1-2.fc14.x86_64
lockdev-1.0.3-5.fc14.x86_64
lockdev-devel-1.0.3-5.fc14.x86_64

How reproducible:
always, even after reboot

Steps to Reproduce:
1. Have kontact configured and use it.
2. Install the F14 KDE 4.6.1 update
3. Start kontact. I'm using it outside of KDE, so akonadi is started on demand now and not on login. A popup "Starting Akonadi server..." appears.

Actual results:
The progress bar in the popup goes either from left till right and back again or only half way until it starts again. It even remains there when I quit kontact.

Expected results:
The progress bar should finish as usual and kontact should be usable but ATM I cannot do anything.

Additional info:
Sometimes nepomukservicestub crashes when I start Kontact. Kontact is completely unusable now.

Comment 1 Christoph Wickert 2011-04-03 11:43:44 UTC
I forgot the version of akonadi. It's akonadi-1.5.1-1.fc14.x86_64.

Comment 2 Christoph Wickert 2011-04-03 13:46:20 UTC
OK, I got it running again, but I had to delete both ~/.config/akonadi and ~/.local/share/akonadi. If I were to use a local address book and not a Kolab server I'd have lost my contacts.

I think the KDE SIG really should revisit their updates policy. Next time you ask FESCo for an update exception I can no longer support it because the fallout from the 4.6.1 update is not trivial. I got three crashes in 2 hours while I hadn't had any for months. drkonqui is broken (bug 693190) and I cannot even report the crashes.

Comment 3 Christoph Wickert 2011-04-03 13:46:52 UTC
Downgrading severity to 'high'.

Comment 4 Kevin Kofler 2011-04-03 17:18:23 UTC
What the heck? :-(

Maybe it's BECAUSE you use a Kolab server that you have the issues, i.e. an incompatible change in the local caching for Kolab address books? That'd explain why this hasn't been seen in our testing.

Comment 5 Kevin Kofler 2011-04-03 23:08:54 UTC
So is there anything we can do about this? If you can't reproduce it anymore after having cleaned up your settings and if nobody else is seeing it, we'll have to close this.

Comment 6 Christoph Wickert 2011-04-04 00:14:36 UTC
I can downgreade and upgrade again but the hassle will only make sense if you have a plan how to debug this.

Comment 7 Kevin Kofler 2011-04-04 01:39:37 UTC
Well, I don't really have a plan which isn't a PITA to test.

The first thing I'd like to figure out is what the exact conditions for the breakage are. In particular, does this happen if and only if the contacts are on a Kolab server? (That'd be my first guess, but the evidence is insufficient to prove or infirm that.)

Comment 8 Kevin Kofler 2011-04-04 01:44:54 UTC
But if you agree with that, we can also just close the bug as INSUFFICIENT_DATA if nobody else is seeing this, given the workaround and the fact that no data was actually lost for you.

Comment 9 Paul Scott 2011-04-04 07:31:09 UTC
I had the same problem. Same solution.

kdepim-runtime-libs-4.4.10-2.fc14.i686
kdepimlibs-akonadi-4.6.1-1.fc14.i686
kdepim-libs-4.4.10-2.fc14.i686
kdepim-4.4.10-2.fc14.i686
kdepimlibs-4.6.1-1.fc14.i686
kdepim-runtime-4.4.10-2.fc14.i686
akonadi-1.5.1-1.fc14.i686
akonadi-googledata-1.0.1-1.fc13.i686 - from thomasj.fedorapeople.org/repo/rawhide
kdelibs-4.6.1-5.fc14.i686
kdelibs-common-4.6.1-5.fc14.i686
kdebase-workspace-libs-4.6.1-5.fc14.i686
kdebase-runtime-flags-4.6.1-1.fc14.noarch
kdebase-libs-4.6.1-3.fc14.i686
kdebase-runtime-libs-4.6.1-1.fc14.i686
kdebase-runtime-4.6.1-1.fc14.i686
kdebase-4.6.1-3.fc14.i686
kdebase-workspace-4.6.1-5.fc14.i686

Kontact starts but hangs when I try to select Calender. I have my calender synced to Google calendar so that may be the reason why Calendar component is hanging, but I mainly use Kontact for kmail. Kmail works ok.

Comment 10 Paul Scott 2011-04-04 07:33:15 UTC
I don't run Kolab by the way... I have a standard IMAP configuration :-)

Comment 11 Kevin Kofler 2011-04-04 07:41:46 UTC
I guess we need to keep this open until we figure out what's really going on there.

Comment 12 Paul Scott 2011-04-04 10:10:45 UTC
I can no longer send mail via SMTP i kmail. I am not running kontact. Kmail just hangs when I click on the send button and waits until I kill it completely. Reading via IMAP is run.

I have removed my Identity and recreated, removed my accounts and recreated. 

This is a showstopper for me so I'll be quickly downgrading unless there are any suggestions for obtaining debug that might be useful to you??

Comment 13 Christoph Wickert 2011-04-04 10:29:19 UTC
(In reply to comment #7)
> Well, I don't really have a plan which isn't a PITA to test.

Even if it's PITA, please tell me.

Comment 14 Paul Scott 2011-04-04 11:18:39 UTC
I have fixed my problem with hanging on send:


I tried a clean kmail installation (moved all the kmail/kontact
directories and files from .kde/share/apps and .kde/share/config but I
still had the same problem.

I had been been using akonadi-googledata-1.0.1-1.fc13.i686 from
tomasj's repository so I removed that. That didn't resolve the
problem.

Next I looked at Akonadi (google data was removed) and I looked at the
server configuration. I ran a test and there were lots of errors
including MySQL server not found etc. I stopped the Akonadi server and
restarted, re-ran the test and they were now all passed except
"Previous Akonadi server error log not found".

Suddenly a "hanging kmail send" which was in the background suddenly
jumped into life and the mail was sent.

I'm not reimporting my folders to the new structure and we'll see if
there are any further problems.

It seems to me that Akonadi is the part at fault here and that moving
away ~/.config/akonadi and
~/.local/share/akonadi doesn't solve the problem completely.

Comment 15 Rex Dieter 2011-04-05 17:30:46 UTC
ok, looks like upstream addresses this @
http://commits.kde.org/kdepim/cfa404b7188e4c26bddbc9579728f6d25f8cd214

Comment 16 Fedora Update System 2011-04-05 17:31:53 UTC
kdepim-4.4.10-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kdepim-4.4.10-3.fc15

Comment 17 Fedora Update System 2011-04-05 17:32:28 UTC
kdepim-4.4.10-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kdepim-4.4.10-3.fc14

Comment 18 Rex Dieter 2011-04-05 17:33:19 UTC
These builds fix one issue where akonadi-launch-on-demand spuriously fails.

Comment 19 Fedora Update System 2011-04-05 20:20:14 UTC
Package kdepim-4.4.10-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdepim-4.4.10-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kdepim-4.4.10-3.fc15
then log in and leave karma (feedback).

Comment 20 Christoph Wickert 2011-04-08 08:35:41 UTC
Please do not push these updates, they are worse than before, at least on F14. 

Akonadi seems to start but kontact no longer works. The UI works but I see a lot of messages on the console and kontact doesn't check for mail or shows the mails I have on my imap server. When I close kontact I cannot open the window again. Instead kontact is reported to have crashed when I logout.

After 5 attempts I managed to get kontact running by launching, closing and killing it. On the second start it works. It seems that it only works if the akonadi stuff has been started before.

Comment 21 Christoph Wickert 2011-04-08 08:36:17 UTC
Created attachment 490734 [details]
Console output when launching kontact

Comment 22 Christoph Wickert 2011-04-08 08:39:54 UTC
I don't think that http://bugs.kde.org/show_bug.cgi?id=268120 is the proper upstream bug for this. It is about the annoying akonadi self test dialog that has been replaced by a backported version of the solution in kdepim 4.6 one, but the backport seems to have negative side effect effects or at least not fix the problems.

Comment 23 Christoph Wickert 2011-04-08 09:06:12 UTC
Ok, after several attempts with kdepim 4.4.10-3.fc14 I am convinced that it definitely does not work:
- Sometimes nepomucservicestub crashes when kontact is launched
- IMAP does not work, kontact hangs at 0% when checking for mail
- kontact is not exited through File -> Exit. In the past that only happened rarely, now every time.
- I have to kill kontact and start it again to get it working. So launching akonadi on demand is completely broken with the new version.

Comment 24 Christoph Wickert 2011-04-08 11:06:44 UTC
Just to make this very clear: After rebooting my computer I cannot use any version, neither 4.4.10-3 from updates testing nor 4.4.10-2 from updates. 4.4.10-1 on the other hand worked perfectly for months. I really don't understand why this update had to be pushed.

Comment 25 Fedora Update System 2011-04-27 16:14:01 UTC
kdepim-4.4.11.1-2.fc14, kdepim-runtime-4.4.11.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kdepim-4.4.11.1-2.fc14,kdepim-runtime-4.4.11.1-1.fc14

Comment 26 Christoph Wickert 2011-05-02 08:05:56 UTC
kdepim-4.4.11.1-2.fc14 is just as broken as kdepim-4.4.10-3.fc14. Actually I think it's not kdepim that is broken but it doesn't work with akonadi-1-5.x. I don't understand why this had to be pushed to F14 at all.

Comment 27 Fedora Update System 2011-05-07 02:53:26 UTC
kdepim-4.4.11.1-2.fc14, kdepim-runtime-4.4.11.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Christoph Wickert 2011-05-07 06:09:46 UTC
Reopening because the problem is not yet fixed. In fact it is worse than before.

Comment 29 Christoph Wickert 2011-05-09 07:11:09 UTC
So where do we go from here? It is worse then ever before and nobody has tested if it works outside of KDE, so if it works when actually started on demand.

Comment 30 Rado 2011-05-11 09:47:08 UTC
I also had problems when I received the update with 4.6.1. This update has an old version of kdepim (4.4 or whatever). Akonadi did not start, etc. When I manually killed everything and started Kontact again it worked until the next login. This has stopped after the upgrade to 4.6.2. Everything works for me now except the acceptance of the Kolab's certificate. I have to manually accept its certificate 4 times every time I connect with Kontact to Kolab.  I does not help at all to click "Permanently accept".

I haven't installed the new updates I am afraid too much to lose access to my mails.

Why was the regression of kmail so back to the history? It works nicely with the latest 4.5. version!

Comment 31 Fedora Update System 2011-05-19 17:36:26 UTC
kdepim-4.4.11.1-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kdepim-4.4.11.1-4.fc14

Comment 32 Christoph Wickert 2012-06-27 10:04:55 UTC
What happened to the kdepim-4.4.11.1-4.fc14 update? Was it ever pushed to stable? Should we just close this bug WONTFIX?

Comment 33 Rex Dieter 2012-06-27 11:55:24 UTC
$ koji latest-pkg dist-f14-updates-testing kdepim
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
kdepim-4.4.11.1-4.fc14                    dist-f14-updates      rdieter

it went to updates

Either way, I guess there's not much we can do now, so WONTFIX fits

Comment 34 Kevin Kofler 2012-06-27 23:30:22 UTC
kdepim-4.4.11.1-4.fc14 went stable, but there was nothing in it compared to -2.fc14 which could have fixed this bug, so the claim that it would fix it was retracted, which explains why the bug hasn't been closed by Bodhi when the update went stable.


Note You need to log in before you can comment on or make changes to this bug.